Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
867 Posts
Hi there and welcome! :thumbs:

Just post your specific problems in their relevant lounges and I'm sure you'll get a better response!

There are a lot of very knowledgable people on this site.

I'm not one of them, but would suggest it's probably the sensor under the passenger seat. Get it checked at an auto electricians with diagnostics and they can tell you if there's a fault with the actual air bag. However, as this is not an MoT failure I (and many others) simply choose to live with it, or even just stick a black piece of tape over it!
 

·
Registered
Joined
·
26 Posts
Yes its a typical Alfa problem - mine has come on after re-set 3 times in the last 5 mths.

Every so often when my wife adjusts the drivers seat the light pops on!

How ever the diagnostic tests very often says diffrent things not related to the wiring being possibly disturbed under the driver seat for the a/bag !

I have heard that you can have the wires soldered into the box under the drivers seat and that often cures the issue.

My probs only occurs like I have said when the drivers seat has been moved.

A diagnostic test and re-set will vary in price dependending on where you take it and only takes about 5mins at tops to do.

Main rule - never have the test done at an Alfa dealership their prices are crazy. Some places will do it for around £20 (cheapest quote i've had) - but its not money well spent if it continues to re-occur shortly afterwards !

The a/bag is diabled when the light is on and from what I'm led to believe an a/bag only gives around a 5-8% improvement to your well being if involved in a prang. Not sure I'd like one smacking me in my face - but if its a toss up between that and the steering wheel then I know which one I'd go for !!!:)
 
1 - 8 of 8 Posts
Top