Alfa Romeo Forum banner

1 - 20 of 52 Posts

·
Registered
Joined
·
179 Posts
Discussion Starter #1
Hi all. So i repleaced the alternator kit, also got a new crank sensor, But still car doesnt start when engine is cold. If im driving a couple off times during the day or so - no problems to start the enggine at all. After leaving the car more then a 5h or so, there is a big chanse - not to start the engine - The only way how to start ir when to put in a 1st gear and slowly pull the car a bit, ones the car is getting like 1 full wheel spin - engine starts. is like +7 till +4 outside during the night. So the only option is to start my engine up time after time and warm it up :mad: Could it be a glow plug fault? Last known error reading was about crank sensor, but that has been repleaced.
 

·
Registered
Joined
·
656 Posts
When you attempt to start does it turn over or click? From what your describing it sounds like stater motor getting stuck, reason why when rocking the car in first it releases..
 

·
Registered
Joined
·
179 Posts
Discussion Starter #3
when i turn the key on the last position before attempting to start the engine it sounds like a click. If it is starter fault, can i fix it or it just needs to be repleaced? also remebered one thing, sometimes when im starting the engine, car vibrates a little bit, sometimes more sometimes less.
 

·
Registered
Joined
·
594 Posts
Have you checked your battery recently? If not it could be that the battery is on it's way out, JTDs require more juice when cold and therefore getting a decent battery with a high CCA is vital.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #6
battery is brand new as well, got it 1 week ago. the thing is that engine is turning fine and the click is only when i turn the keys in last position before starting engine, like today i started on first try - like no problems :) i hope its not because car was lef on a curb and fuel gauge showed emty tank? :cheese:
 

·
Registered
Joined
·
9,912 Posts
i would make sure all connections to battery and to chassis and starter motor are good ..failing that go to an auto spark who will have eguipment to check
 
P

·
Guest
Joined
·
0 Posts
I had a similar problem on mine mate, turned out to be a faulty fuel pump relay. the relay box is at the front of the engine bay near the headlight. Hope it helps:)
 

·
Registered
Joined
·
179 Posts
Discussion Starter #12
just two questions,

1. is that fuel pump relay the same for all 156 alfas? or is there a special one for 2.4jtd 10v?
2. were can i get it ? cant find it on ebay :rolleyes:
 

·
Registered
Joined
·
179 Posts
Discussion Starter #14
only God knows. i was told that 4 of them are new one, but i dont trust them, but one plug is old one , i know that for sure.
 

·
Registered
Joined
·
1,322 Posts
It's not the glowplugs, they make practically no difference to starting a JTD at above freezing temperatures. I think Propellorhead could be on the right track with the fuel pump relay. There are several similar relays in front of the battery, try swapping them round. Does the pump in the fuel tank run when you switch on? It should be audible for a moment.
 

·
Registered
Joined
·
179 Posts
Discussion Starter #16
yeas i can hear some kind of sound, sounds like fuel pump does kind of quiet sssssssssssss sound :)
 
P

·
Guest
Joined
·
0 Posts
It's not the glowplugs, they make practically no difference to starting a JTD at above freezing temperatures.
I did wonder about that as when I changed my fuel pump relay, I actually just swapped the glow plug one with the fuel pump one. I'm ashamed to say its been like that ever since!:eek: Only thing I saw that was different was after startup the glow plug light flashes a few times then goes out, I'm guessing this is due to the faulty relay now being in the glow plug spot.

Mild winter here so no below zero starting issues (yet!) :thumbs:
 
P

·
Guest
Joined
·
0 Posts
where can i find that glowplug relay? :) sorry im just a noob in those things :)
I'll take a pic of mine toniGht when herself is back, on my 1.9the relay box is at the front next to thepassenger headlights
 
1 - 20 of 52 Posts
Top