Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter #1
Collected my new 166 from the garage on Saturday and have spent the last 3 days taking the car out for nothing other than a spin and I haven't done that for months. Really, really,:) pleased and it's great to be behind the wheel of an Alfa again, everything just feels so familiar. But as always a few niggles and possibly one major one that I shall have to go back to the garage with, so any suggestions much appreciated.

Minor niggles

Squeaking clutch pedal. I have read the threads on this and so easy to sort I believe.

Driver heated seat switch doesnt stay down, but held in seat does stay hot. Particuarly annoying as when I tested the car this did work!!!

After putting £20 fuel in, the estimated miles left in tank on the trip stays blank.

Major

I noticed last night with it being colder, I put the heater on and the temp gauge dropped to about 80 and climbed to 90 when turned off. Today with no heater on it wouldn't get to 90, stayed around 80. Though it was very cold. When i put the climate on full manual, I'm sure my other 166's had a more powerful flow of air coming out of the vents. Could this be temp sensor, water pump or radiator related? (The aircon blows very cold)

Otherwise no noise from suspension, variator and and it's ace!!!!

Off to Sennen in Cornwall on saturday, so hopefuuly no problems.

Ta Nickd
 

·
Registered
Joined
·
6,165 Posts
Mine does that! Shouldnt worry about it, as long as the fan kicks in about 90 youll be fine

Plus done forget its been cold the last few days!
 
1 - 3 of 3 Posts
Top