Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi all,

Iv just purchased my first ever alfa and tbh i really wish id of got one before, what a lovely car (2003 147 t-spark lusso).
The only problem that has occured is that my display is showing the words "ABS & VDC system failure" everytime i start the car then the ABs light & a triangle with an arrow surrounding it also shows. I have also noticed that on the centre console there is a button with ASR with the red light on and it dont seem to do anything when i press it.

Any help or info with what i can do to remove these messages would gratefully be appreciated,

Many thanks.
 

·
Registered
Joined
·
1,582 Posts
Sounds like your ABS sensors might need replacing or a good clean, but I had the same problem until i changed disc pads, so check them also.
 

·
Registered
Joined
·
5,999 Posts
Does it happen all the time ? When it happens,turn the engine off and then restart it.

If it goes off this time,you might have a dodgy battery.

If always on..Hazz37 is probably right.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #4
Thankyou guys, will have a look asap.

Ronan, the messages show everytime i start the car the moment i turn the key.

Been reading about so many possible fixes to similar problems on here my mind is baffled lol
 

·
Registered
Joined
·
143 Posts
Firs check that the switch on the brake pedal is sitting well in its place and if it is making contact.
Do the brake light come on when you brake?

If not, the switch isn't working and that causes the ABS and VDC not work either.

Cheers!
 

·
Vendor
Joined
·
46,124 Posts
First place is to plug into diagnostics and find out what fault is showing as present to cause the light to come on! :)
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Fault found and fixed now my friends :)
I had the car plugged into a diagnostics at a local garage and it came up with a dodgy nearside front ABS sensor.
Bought it from a local motor factors for the price of £35 +VAT, came home and fitted it, turned the key and wow nomore beeps and a non blackpool lights looking dash display :cool:

I appreciate all your help and comments, Cheers
 
1 - 8 of 8 Posts
Top