Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi everyone need some help on my 147 2002(2litre lusso) as i am not an exspert and not rich either, just trying to fix problems myself if possinble.

i have a abs light on and the vdc light on as soon as i start car and are on constant i never had o lights until i left my car jacked up for 2 days and chnged front right upper wishbone and the front left bearing unit, after i fixed it all up i dropped car it was a bit low on the juice to start but it did and thats when i got the beeepbeeep. and the abs and vdc lights come on and stay on i have read alot into it and have a big list just wondering if anyone can give me more detail to it, have i cracked the abs ring when putting bearing, or twisted sensor(which i checked and seem fine) my battery is only got 430cca and its recomended no less than 600 so can it be the battery?

i have a list of jobs for my wee alfa and this has just added to it:paranoid:
its been a pain so far like problem after problem:censored:

any help is appreciated thanks guys
 

·
Registered
Joined
·
30,221 Posts
...it was a bit low on the juice to start but it did and thats when i got the beeepbeeep. and the abs and vdc lights come on ...
Did you take the battery out and charge it properly after that?
 

·
Registered
Joined
·
30,221 Posts
They do get upset with a low battery, so is an easy thing to check first.
 

·
Registered
Joined
·
6,973 Posts
Basic rule of fault-finding: first check the last thing you touched!

Your best course of action would be to get the fault codes read - much cheaper in the long run than throwing random parts at it in the hope of finding a cure.
 
1 - 6 of 6 Posts
Top