Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
743 Posts
Discussion Starter #1
took the spider for its test today and it passed with only 2 advisories , drove sweet on the way there BUT coming back was a whole different story , felt like i had two clutches ! by the time i'd reached the garage i could feel a grating threw the clutch pedal ! :mad: , so the gearbox needs to come off as the release bearing is fubared ! it was all going sooooo well !
 

·
Registered
Joined
·
2,197 Posts
what was the clutch like before you took it for the MOT..
did you check the mileage before and after..
A young mechanic hasn't been for a 'joyride' has he ??
 

·
Registered
Joined
·
373 Posts
Mine did exactly the same thing a fortnight ago. Today after almost £800, a new clutch, pressure plate, thrust bearing, flywheel slave cylinder and a few other things she is running sweet as a nut!
 

·
Registered
Joined
·
743 Posts
Discussion Starter #5
Mine did exactly the same thing a fortnight ago. Today after almost £800, a new clutch, pressure plate, thrust bearing, flywheel slave cylinder and a few other things she is running sweet as a nut!
i'm going to swap out the thrust bearing and all will be well again ,
 
P

·
Guest
Joined
·
0 Posts
Mine did exactly the same thing a fortnight ago. Today after almost £800, a new clutch, pressure plate, thrust bearing, flywheel slave cylinder and a few other things she is running sweet as a nut!
did you go for the lightened flywheel option? or standard dual mass?
 
1 - 9 of 9 Posts
Top