Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1,808 Posts
Discussion Starter #1
AAAAAAAAAAAAAAgh! :rant:

Fitting my strut brace which should have been a half(ish) hour job. move the various bit out of the way, no problem.

tried undoing the top strut bolts CRACK!!!! either the bolt or plate has sheared
Why is it that Alfa only use bolts that shear when you undo them.... :rant:

Anyone know whats involved in removing a strut, just a few more broken bolts or do I need all those special tools that Alfa love so much

Doh!

san :rant: :rant: :rant: :rant:
 

·
Registered
Joined
·
4,651 Posts
San the strut is held in with 3 bolts on the top of the strut............2 now in your case :rolleyes: :p and 2 bolts onto the hub and a clamp for the brake flexi ;)

Once they undone the whole lot will lift out from the car

Btw have you tried drilling the broken bolt out and re-tapping the thread???You should be able to do this WITHOUT removing the strut ;) :D
 

·
Registered
Joined
·
1,808 Posts
Discussion Starter #3
speed freak said:
San the strut is held in with 3 bolts on the top of the strut............2 now in your case :rolleyes: :p and 2 bolts onto the hub and a clamp for the brake flexi ;)

Once they undone the whole lot will lift out from the car

Btw have you tried drilling the broken bolt out and re-tapping the thread???You should be able to do this WITHOUT removing the strut ;) :D
The bolt won't come out so I have a feeling that the top plate has sheared
(nsf bolt BTW)
Will have another go in the morning

san :mad:
 

·
Registered
Joined
·
4,651 Posts
Aaaah i thought you meant it had snapped :rolleyes:

Probably just the Captive Nut that`s broken off the top mounting plate then :rolleyes: .................You might have to cut the old bolt off and then just put a Nut and Bolt through or drop the strut out and weld a new nut on ;) :D
 

·
Registered
Joined
·
1,808 Posts
Discussion Starter #5
Ah not as bad as I thought then

Good job I didn't put me lump hammer through the windscreen or worse :D


san
 

·
Registered
Joined
·
1,808 Posts
Discussion Starter #6
Many thanks Speedy

Its all done now, took about 2 hours, :eek: and yes the welds had broken on the captive nut (must have been a Friday afternoon weld :D )

Cheers

san
 
1 - 7 of 7 Posts
Top