Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1,172 Posts
Discussion Starter #1
Started my car this morning to go to work, car was well frozen up, only got round the corner and it flashed up VDC system failure (I think it said VDC!) Then ABS sytem failure, go to dealers!
Now what i'm thinking is as the car has sat there all night how can it just have two major faults without moving? I'm kinda hoping the brakes where iced up so its saying there is a fault when really once defrosted it will be ok? I may just have to have the warning reset via laptop or something? Once the light came up i turned around and didn't drive the car! Any help or advise would be great!
Thanks
 

·
Registered
Joined
·
855 Posts
My ABS light keeps coming on all tehe time, when cold and snowy, and after abuse of hanbrake :) . I think its only snow getting in the sensors.
 

·
Registered
Joined
·
953 Posts
Started my car this morning to go to work, car was well frozen up, only got round the corner and it flashed up VDC system failure (I think it said VDC!) Then ABS sytem failure, go to dealers!
Now what i'm thinking is as the car has sat there all night how can it just have two major faults without moving? I'm kinda hoping the brakes where iced up so its saying there is a fault when really once defrosted it will be ok? I may just have to have the warning reset via laptop or something? Once the light came up i turned around and didn't drive the car! Any help or advise would be great!
Thanks
I've had this problem with my 147 for the last 6 weeks or so.
Many suggest the battery could be on the way out, I don't have a volt meter but checking the voltage with AlfaDiag it says the battery is putting out about 12.4 volts which apparently is an indication that the battery is shagged.

I have just ordered a new battery.

It's a Varta Silver Dynamic type 027 (Short Code D15)

Specifications
Voltage - 12V
Capacity - 63Ah
CCA(EN) - 610A

Dimensions(mm)
242 x 175 x 190

It comes with a five year warranty - cost about £85 including the shipping from Tayna Batteries.

Hopefully this will solve the problem, if it doesn't then i'm gonna replace the switch at the top of the brake pedal (another forum recommendation) about £15 from the Stealers.

If you have access to a volt meter then try checking the output from your battery with the engine off and post back.
 

·
Registered
Joined
·
1,172 Posts
Discussion Starter #5
Thanks chaps! I'm in a right mood about my car! The fact it don't even work if its cold!
 

·
Registered
Joined
·
1,172 Posts
Discussion Starter #7
Cheers for that link! Its reasuring to know it should sort its self out! just had a horrible feeling it was gonna be expensive!
You sort of panic when your car starts flashing up all sorts of lights!
I should just relax a bit and remember i'm in an Alfa!
 
1 - 9 of 9 Posts
Top