Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter #1
Had the 159 for 2 weeks to the day and that's it being towed away to Western Alfa in Perth.

It's developed a judder / misfire and an increase in oil level.

:cry:
 

Attachments

·
Registered
Joined
·
45 Posts
Discussion Starter #4
This will sound strange.... but did you smell or sniff the oil before it left for Western:confused:
No I didn't. But, this will also sound strange, I thought there was a smell not unlike aircraft fuel from the car. Never had a smell like that from a car!
 

·
Registered
Joined
·
45 Posts
Discussion Starter #6
I'm too busy next week I think, so prob won't be me looking at it....
Laura and Willie know about it as I was in past a week past Wednesday and Willie took it for a drive to see what the problem was. I'll give them a call in the morning.
 

·
Registered
Joined
·
551 Posts
No I didn't. But, this will also sound strange, I thought there was a smell not unlike aircraft fuel from the car. Never had a smell like that from a car!
Indeed! Only reason I ask is I recently saw an Audi diesel getting packed off to a scrappers as the owner mysteriously found more oil in his sump. He was running a diesel tuning box (ebay special) which had given him big power but (quote) "loads and loads of crappy black smoke". On sniffing the dipstick it was clear the sump was full of oil/diesel mix. Now I've come across that sort of bore-wash before (on a Range Rover V8 - fuel in sump) but never on a diesel.

I've wondered how it was possible on a turbo diesel unless it was seriously seriously over-fuelling and fuel was just being blown down into the sump

Anyway, hope it's not that serious for you and is quickly fixed :thumbs:
 

·
Registered
Joined
·
3,255 Posts
Laura and Willie know about it as I was in past a week past Wednesday and Willie took it for a drive to see what the problem was. I'll give them a call in the morning.
Willie is on 2 weeks holiday just now. I remember seeing the car before now that I have seen it in the compound.
 

·
Registered
Joined
·
3,255 Posts
Yes it was. They've opened a case with Alfa Technical. Oil level way over the max again so oil, filter and forced re-gen is the first port of call.
Yea seen the Tech doing the oil and filter change today then going for road test, Sure its back on the ramp again though. Place is really busy just now, no time to stop for a sec this week :cry:
 

·
Registered
Joined
·
45 Posts
Discussion Starter #12
Yea seen the Tech doing the oil and filter change today then going for road test, Sure its back on the ramp again though. Place is really busy just now, no time to stop for a sec this week :cry:
Yeah it broke down on the road test and had to be recovered! Fuel pump ordered from Italy on a "first time fit" (4 day delivery) so they can return it if it's not that. Going to stretch into next week now :(
 

·
Registered
Joined
·
45 Posts
Discussion Starter #14
Yes. I got the car back on Wednesday after 4 1/2 weeks in Western. It was the sensor on the fuel rail which was causing the car to over fuel which led to an increase in the oil level, blocked DPF and clogged exhaust!
 
1 - 16 of 16 Posts
Top