Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi guys, got a few problems here i hope you can help with

After owning a fiat, i swore i'd never own another Italian car, but after driving my mates 156, i quickly changed my mind (wish i hadn't)
]
Its a 1999 156 1.8 tspark

i replaced the Maf sensor when i got the car as he said it had gone, as it was suffering idle and power problems, done that, car ran fine.

Now im the proud owner, and im having idle problems the car when warm the rev counter will go from just over 1500 right down to 0, then the car studders like hell to the point of conking out, this repeats click clock work with no stop.

Also while driving the car to the mot center, the car was juddering really bad, so bad i felt like the brakes had suddenly been applied then released, causing the car to become so bad, i had to turn around and go home, £30 wasted

lastly when moving very slowly, (less than 5mph) and you put the car into 1st, the gear box grinds as if you didn't push the clutch properly ( which i have believe me lol)

can anyone shed some light?? i didnt find anything that gave me a definite answer while searching, i hope i didn't miss a post and look like a right wally
 
L

·
Guest
Joined
·
0 Posts
1st gear: the synchro is probablly damaged.

air meter: was it a new sensor? or 2nd hand? Was it a Bosch unit or not?

I'd suspect teh air flow meter is defective or if its new then the corrugated pipe after the MAF is torn
 
L

·
Guest
Joined
·
0 Posts
1st gear: the synchro is probablly damaged.

air meter: was it a new sensor? or 2nd hand? Was it a Bosch unit or not?

If 2nd hand I'd suspect the air flow meter is defective or if its a new MAF then the corrugated pipe after the MAF is torn
 

·
Banned
Joined
·
3,532 Posts
You idle problem is 99% most likely the idle control valve, I had the same problem on my 145QV so bought a new one and had it setup by Alfa (as they seem to be the only people who can do it) and it worked a treat :thumbs:

2nd issue maybe warped discs...

3rd issue a problem with the gearbox :(
 
L

·
Guest
Joined
·
0 Posts
i don't think the OP was actually saying the brakes were making the car shake but that the car driving so bad it felt like the brakes were been applied, i could have read the post wrong
 

·
Registered
Joined
·
5,621 Posts
check the corrugated pipe on the air intake, check it very carefully they are very prone to splitting in the grooves leading i had the same issue on my GTV it's amazing the problems a couple of little splits can cause i believe replacements can be gotten from EB spares
 
1 - 9 of 9 Posts
Top