Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
73 Posts
Discussion Starter #1
Hi guys just posting on the off chance that anyone has the solution, or if it's something to just put up with.

When the key is turned so the electrics are on before the engine, a whirring noise comes directly from the small left vent on the a/c control panel. This is with the a/c turned off or on, it doesnt matter. It continues when the key is turned again to start the engine.

Ive bought a second hand a/c panel off Ebay and swapped the tiny fan round but no joy, it still has an irritating noise.

Does anyone else have this problem? Ive a 2004 156 gta. Cheers!
 

·
Premium Member
Joined
·
7,694 Posts
Usually it's caused by a build-up of dust in the small fan (which contains the interior temp sensor)
Cleaning it (blowing it out with compressed air) usually solves it
 

·
Registered
Joined
·
73 Posts
Discussion Starter #3
Thanks ive got my compressed air and screwdrivers ready. Any idea how to remove the a/c panel from the cars dash? Im trying now but its not immediately obvious how it comes off!
 

·
Premium Member
Joined
·
7,694 Posts
Thanks ive got my compressed air and screwdrivers ready. Any idea how to remove the a/c panel from the cars dash? Im trying now but its not immediately obvious how it comes off!
not sure how that works on a 156, only familiar with the 147......
However, I'm sure someone else will jump in .... ;)
You could try compressed air through the small grid, as a first attempt

however, you mentioned you exchanged the fan..... How did you do that ? :confused:
 

·
Registered
Joined
·
73 Posts
Discussion Starter #5
Ashamedly, I paid autotec garage to do it :( But its still making the noise, i think the one i got off Ebay should have been cleaned before they installed it.

Ive given it a few squirts from the front hrough the tiny vent with the a/c panel in situ, but that had no effect.

Ive unscrewed and cleaned my other a/c panel fan, and its ready to be swapped
 

·
Registered
Joined
·
73 Posts
Discussion Starter #7
Thanks. That looks a bit beyond me and my one screwdriver. I will take it to a garage to do next Tuesday. I will update on here if the noise is gone, cheers!
 

·
Registered
Joined
·
73 Posts
Discussion Starter #8
I have cleaned out the fan with compressed air squirts thoroughly and switched it over, but there is no difference, the buzzing sound remains. Because it happens which ever a/c panel was in there (the dust free fan and the other fan), it makes me think it must be something else, not the panel or fan itself, but something behind it. Idk.
 
1 - 8 of 8 Posts
Top