Alfa Romeo Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
1,488 Posts
Discussion Starter · #1 ·
Hi Everyone,

I'm after for A/C condensers for my 33, fan not required.
On my condensers the aluminum fins are corroded beyond repair
on some areas, they not able to exchange the heat efficiently anymore.

If someone knows a decent one (or pair) for a decent price,
please let me know.

Thank you
 

Attachments

·
Registered
Joined
·
3,000 Posts
Lonewolf,

I think the really helpful chap from Norway / Sweden / Finland / Denmark had a set for sale recently. I can't quite remember his tag - I think it is something like Rejinders. (sorry if I got a lot of that wrong - :eek: )

He, if I remember correctly, had a full A/C system - but no harm in asking. :)
 

·
Registered
Joined
·
1,488 Posts
Discussion Starter · #6 ·
Hi Thanassis,

It would be great!
I guess you still have my e-mail address (regarding the water intercept valve for the A/C),
if don't, please let me know.

Thank you!
 

·
Registered
Joined
·
1,488 Posts
Discussion Starter · #9 ·
New condensers from scratch

... and finally the new condensers were arrived two weeks ago,
they're fabricated from scratch. Both condensers has been
installed this week (fan units + air deflection frames).
Now I need a few O rings to perform the pressurization test,
hopefully it will be done on next Monday.
 

Attachments

·
Registered
Joined
·
3,000 Posts
Looking very good. :thumbs:

It is good to see that it is possible to get things like this re-made. I do think that with certain parts, it is almost easier to try and get things fabricated rather than spend forever trying to find that elusive serviceable item.

Nice one.

Will be interesting to hear how you get on with the remainder of the install. :cool:
 

·
Registered
Joined
·
1,488 Posts
Discussion Starter · #11 ·
Thanks Edward.

Yes, many obsolete parts can be re-made, it's matter of time and wallet thickness.
Today I got the replacement O-rings and I've finished with the A/C system hose connections.
Late afternoon the pressurization test was performed with nitrogen. It seems the system is holding the pressure. I've attached some photos.
 

Attachments

1 - 11 of 11 Posts
Top