Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hey guys,

my coolant temp. gauge have been dead for a while, so have decided to change the sender unit for the gauge. This is the only car I have access to, so just wanted to make sure I dont need to go to the shop and buy any gasket material or so when I'm in the middle of fitting it? I see it it a metal o-ring that I guess is there to seal it. If any of you have any pictures of the location or so, I'd also appreciate it. :)
 

·
Registered
Joined
·
1,309 Posts
Hi

no just the temp sender needed and maybe a little ptfe tape if you have any
 

·
Registered
Joined
·
3,007 Posts
There's 2 sensors on your car, one that feeds the gauge and the other is for the ecu. They're both found in the lower half of the thermostat housing. (above the flywheel)
 

·
Registered
Joined
·
14 Posts
Discussion Starter #5
Thanks for the answers guys! I took everything neeeded apart yesterday, and was going to unscrew the sender just to find out my wrench was to small. Had checked that my wrench fitted the unit I was going to replace it with, but since its not original I guess the heads are different. Anyone know the dimension of the original unit?
 

·
Registered
Joined
·
14 Posts
Discussion Starter #6
Anyone? I see Elearn says the threads is M12, but it doesent say anything about the socket/wrench size. My only car, so if I don't get it right I have to put everything back togheter, and then goto the shop :p
 
1 - 6 of 6 Posts
Top