Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
377 Posts
Discussion Starter #1
Today turned out to be the most irratiting day Alfa ownership so far ... more than likely caused by it's inept owner :rolleyes:

I finally get my 24mm socket from ebay so I decide to fit the leather steering wheel and carbon centre console i got form Iainfm, centre console went on fine and looks amazing compared to that wooden nonsense. Next the steering wheel, having gone about removing the last one from Iains car it looked, and was, a simple job (have done it before on a Bravo)...second time unlucky!!!

First off the airbag connector fell apart, this may explain why the light has been on, then when I took the wheel off the whole wiring loom behind it disintegrated and all the ribbon wire unspooled!!! I respooled it and put it back together and the final thing looked great but I put it on squint...I also coiled the ribbon cable too tightly and ripped it out on the first right turn :lol:

Get home and straighten the wheel but now I have no working horn or airbag :( so I need that part behind the wheel:

http://i213.photobucket.com/albums/cc90/imclaren/breaking/01092008379.jpg (courtesy of Iain)

If anyone has this section for sale please PM me!

The story continues...

I go to my mums to pick up a tumble dryer but the car fails to start, I eventually see that the positive clamp keeps slipping off - I've not touched that for months, why now???!!!

With that fixed I get said tumble dryer but upon putting in the car I lose grip and put a lovely 12" scratch down the rear quarter panel, right down to the fackin metal work. Scratches don't bother me but I put 2 small dents in the too :cry:

Almost at the thrilling conclusion...

Feeling dejected after another failure to start and subsequence clamp wiggling I'm driving home and realise I'm doing 0mph but the trip computer is doing 1 mile for every 5ft the car moves!!!! Also the mileage is going between ****40 and ****47 very fast :confused:
All the other gauges are working fine and I have no idea how to solve this one.

After getting my head round this I'm driving through Anniesland and some nugget in an Astra keeps tailgaiting me and keeps trying to cut me up...very good, I'm in no mood so I leave her in amongst the traffic with some fancy driving and smoke screens :lol:

Any suggestions about the above electrical gremlins would be appreciated :thumbs:
 

·
Registered
Joined
·
1,219 Posts
i have no idea how to cure you gremlins but may i suggest you dont touch it again god knows what could happen
 

·
Registered
Joined
·
7,032 Posts
a bad connection (I had something similar when the mileage counter started to go like crazy) turned out to be a connector at the back of the battery.... I wish you strenght !
 

·
Registered
Joined
·
26,529 Posts
Remind me not to let you near my car !!
 

·
Registered
Joined
·
377 Posts
Discussion Starter #7
a bad connection (I had something similar when the mileage counter started to go like crazy) turned out to be a connector at the back of the battery.... I wish you strenght !
That's the one that's loose, but I can't seem to tighten the bolt any further...think a new clamp will need to be order :(

Normally I'm quite competent with car things but yesterday must've been an off day, should've stayed in and played Burnout Paradise :lol:
 

·
Registered
Joined
·
377 Posts
Discussion Starter #8
Also, the brakes on her Streetka packed in yesterday, never ending problems with those and I've been nowhere near it :lol:

So I'm not almost totally without transportation - I'll probably break my legs at lunchtime in some freak slipping on a banana skin incident :lol:
 

·
Registered
Joined
·
7,032 Posts
Murphys law !!! and you know Murphys second law ?

Murphy was an optimist
 

·
Registered
Joined
·
26,529 Posts
Any banana skins ??? :lol:
 
1 - 12 of 12 Posts
Top