Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
On my way to Wales my Gtv died - no warning.
Trying to re-start it would fire and run for a second or maybe two then die.
Following recovery I tried replacing the Crank sensor - no success
I then took the MAF apart and cleaned it - it ran for the length of 100yrd road and died again.
Unplugging the MAF allows the engine to run on generic settings that would normally be varied by the feedback from the MAF sensor. The car runs a little rough but feels faster - maybe as a comparison to the failing MAF ?
The fault is likely to be attributed to a 2.0 litre (shorter) Air filter being fitted to the 3.0 litre airbox allowing unfiltered air to run into the MAF - a common problem - also linked with using aftermarket K&N type filtration which contaminates the MAF with filter oil.
Alfa Dealer wanted £230 for a replacement refurbish unit and exchange on failed part
Motor factors £202 for a patent part
in the end I chose to replace just the sensor (dismantle with security torx bit - 2 screws) from Ignition Parts - Ignition Car Parts for £60.90p delivered.
I will post an update if this cures the problem
 

·
Registered
Joined
·
37,347 Posts
Is it a genuine bosch element?

You should really only use genuine bosch elements as the pattern ones don't tend to work very well.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
Its not - Im going to take the chance - some are ok some are not - this supplier was recommended to me. Plus it has a 3yr waranty over the 1 yr Bosch offer
 
1 - 4 of 4 Posts
Top