Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Last week I noticed my EML was flickering above 4500rpm (on a 2000 3.0 24v GTV). By flickering, I mean that at around 4500rpm upwards, the red fuel injector style light was glimmering. Not fully lit, flashing on and off irregularly, but doing that pretty much up to when I shifted to the next gear.

After searching the web, no immediate solution was found. Use of MultiECUScan showed no fault codes stored, and replacing the AFM did not improve this.

I am posting here as I got the solution through discussion on the 916 technical FB page, in the hope that if anyone else has a similar issue, a web search will bring this page up.

My solution turned out to be dead simple based on someone else's experience of the same.

Check the ECU earths, specifically the one that bolts to the casting that supports the engine end of the top engine steady bar, and the nut that holds the injector loom earth onto the front head just below the oil filler.

Both of these were loose, so likely at higher revs/vibration higher resistance was present as they moved. Likely my fault as had recently done a pair of head gaskets on this car and probably fingered tightened them and got distracted before fully tightening them.

Tightened them up, did an ECU reset (new AFM), and right as rain.

Hope this is helpful to someone in the future.
 
  • Like
Reactions: cgc

·
Registered
Joined
·
241 Posts
Brilliant advice (not sure if you're still on here to hear it though) - the earth near the oil filler was very loose.....solved the problem. Genius! Thanks you.
 
1 - 3 of 3 Posts
Top