Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Hi there

I can seem to get a good seal on the clamp that bolts the turbo down pipe on it it has a very slight leak?

Is there a gasket between the joint ?
Is there a knack
Or do they all leak a bit ?

any advice would be gratefully received

thanks andy
 

·
Registered
Joined
·
362 Posts
It shouldn't leak at all..

clean the pipe/flange with carb cleaner so there is no oil at all,
make sure the pipe isnt damaged,
give the mating surfaces a quick spray of hairspray,
clamp using a good quality jubilee clip, not one of those aluminum ones with holes for grooves.
 

·
Registered
Joined
·
30,171 Posts
clamp using a good quality jubilee clip...
I think he is talking about the exhaust...

Looks like there is a clamp where the Cat joins onto the downpipe.

Not something a Jubilee clip would work on!!
 

·
Registered
Joined
·
362 Posts
I think he is talking about the exhaust...

Looks like there is a clamp where the Cat joins onto the downpipe.

Not something a Jubilee clip would work on!!
ah my mistake, I thought he was talking about the turbo-intercooler pipe.
 

·
Registered
Joined
·
822 Posts
Are we talking about the bulbous cat between manifold and turbo? This gets taken off for the oil change and is a bit of a swine to get back. I've only had mine off the once so cannot 100% remember but the two ends are clamped together by a split ring. I suspect it may not be on quite right or has been damaged by a ham fisted removal/replace in the past.

Mine certainly does not leak.

Keith
 

·
Registered
Joined
·
41 Posts
Discussion Starter #6
thats the one Keith !

is there a gasket or something between the two mating faces??

my clamp is in good condition and I didn't have to remove precat down pipe when changing oil filter, I just slackened the clamp enough and just swivelled the down pipe towards the rad so I could get my hand in to remove the the smallest oil filter in the world !

it was sooty in this location before I started so must have been leaking from previous owners ownership ?

any thoughts ?
 

·
Registered
Joined
·
822 Posts
Well done for getting the oil fiilter out without remving the cat!! My recollection is that there was no gasket. Rather the clamp forces the two tapered ends together. It was hard for me to get the clamp seated properly. Is yours definately properly seated around both pipes? If so might be worth replacing the clamp. Its also possible that someone may have trapped the clamp between the two faces at some point and damaged the sealing faces?

Keith
 
1 - 8 of 8 Posts
Top