Alfa Romeo Forum banner

1 - 15 of 15 Posts

·
Registered
Joined
·
81 Posts
Discussion Starter · #1 ·
Discovered the screech on startup is unrelated to the aux belt/ tensioner and is actually coming from the starter motor.

How easy are they to replace (95bhp non turbo).
 

·
Registered
Joined
·
9,347 Posts
Does it screech as the engine fires and starter stops? Especially when engine is cold?

Getting that too. '59 1.4 NA like yours

On my 'to-do' list for 2019 but haven't yet looked into 'how' or 'how much'
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #3 ·
Does it screech as the engine fires and starter stops? Especially when engine is cold?

Getting that too. '59 1.4 NA like yours

On my 'to-do' list for 2019 but haven't yet looked into 'how' or 'how much'
Sure does, the internet is awash with the tensioner and aux belt issue which I initially wrongly thought was my issue. Replaced them with OEM items but the problem soon came back. Only when I got someone to start the car with my head under the bonnet did I realise it was from the gearbox side of the engine.

Sometimes you can stop it happening if you prematurely stop turning the key , on the lookout for a replacement starter motor now.
 

·
Registered
Joined
·
72 Posts
My QV is also doing this lately :(
Because so many opinions on here state it's the aux belt, that's what I was starting to think it was and was looking to get it changed.

I'm not too sure on what to do.
 

·
Registered
Joined
·
9,347 Posts
If it does it when the engine is running, then it's possibly the aux belt.

But for me it only happens when the starter is run and only as the engine fires, so it's definitely the starter. It is definitely coming from the starter motor area too .. right side of engine as you look in the bonnet.
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #7 ·
This has to be a joke ? 2 bolts, 1 pictured, the other one is 180 degrees from the first , how do I get to it ?!
 

·
Registered
Joined
·
9,347 Posts
Beginning to think this might be a job for my favourite garage!

Sockets, extensions, swivel-joints, ... and a lot of luck finding the screw head?

Is it only the two screws? The pics of MiTo starters I've seen have what look like three mounting holes?
 

·
Registered
Joined
·
69 Posts
Mine is fixed with 3 bolts. One or two is accessible from gearbox side - can't remember it exactly. It occurred to me while swapping the gearbox on my QV. If it is the same on your MiTo, you will have to remove the battery and its tray to gain access to the bolts in question. Hope this helps.
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #11 ·
Brill thanks for the help

There is a metal dowel that situates the starter , that is at 90 degrees (the top). But from what I can work out from looking at my new unit just 2 bolts.
 

·
Registered
Joined
·
9,347 Posts
How did it go pete_h? Or hasn't it?
 

·
Registered
Joined
·
81 Posts
Discussion Starter · #15 ·
Pleased to say the issue is now resolved. Replaced the starter just now, battery and tray out and the top starter bolt is on the outer gearbox casing.



Working from underneath to do the bottom bolt and connection at the rear is straightforward, just a little right if using a trolley jack/axle stand.
 
1 - 15 of 15 Posts
Top