Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Im at my wits end with this roof sticking in the same position. doesnt stickwhen going down, but when going up it sticks just as the back panel tries to lock down befor the window part comes down, ive read every spider roof post and tried nearly all the solutions, ive had it into a local garage and they couldnt find any thing wrong, it looks like its going to have to go into a dealers at over a £100 per hour labour, can anyone give me any ideas why its doing this, i have to stop the engine and persevere, eventually it goes down :furious:, anymore and im seriously thinking about selling, i love the car but its doing my head in
 

·
Registered
Joined
·
7,548 Posts
You've no hope of selling a convertible with a roof that doesn't fully work.
If you want to get rid, get it fixed then advertise straight away before it starts playing up again.
That's my plan anyway.

In the meantime get out of the car and push the various parts to the next stage by hand.
Then back on the button.
 

·
Registered
Joined
·
238 Posts
Im at my wits end with this roof sticking in the same position. doesnt stickwhen going down, but when going up it sticks just as the back panel tries to lock down befor the window part comes down, ive read every spider roof post and tried nearly all the solutions, ive had it into a local garage and they couldnt find any thing wrong, it looks like its going to have to go into a dealers at over a £100 per hour labour, can anyone give me any ideas why its doing this, i have to stop the engine and persevere, eventually it goes down :furious:, anymore and im seriously thinking about selling, i love the car but its doing my head in
I agree with VeloceRagno, sounds like the flap motors,not too expensive to replace
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
Bit of a update, had a go myself after looking at loads of spider related roof problems, disconected the battery for 10hrs, unplugged both flap motors and lubricated most parts, put it all back together and hey presto its working fine, had it up and down quite a few times and never stuck once, hope its cured itbut keeping my fingers crossed :thumbup:
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Stuck again today so back to square one :furious::furious::furious::furious::furious::furious:
 

·
Registered
Joined
·
1 Posts
i have same problem.when opening the hood there is no problem but when close the hood it completed %90 then stopped and not completed.
anyone solve this probelem?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
i have same problem.when opening the hood there is no problem but when close the hood it completed %90 then stopped and not completed.
anyone solve this probelem?
Hi Atreus
Once again i unplugged the flap motors and this timesprayed them with WD40 in both the plug and the motor, used it about 5 times since and no problem up to now
 
1 - 8 of 8 Posts
Top