Alfa Romeo Forum banner

1 - 19 of 19 Posts

·
Registered
2010 159 2.0JTDm Ti
Joined
·
38 Posts
Discussion Starter #1
Hi guys,

My 2008 2.4 Brera SV is running bad. Bought the car, drove it for 9 days and now it's been at the dealer for a month!

The problems are as follows:

1) Starts fine, but is hunting/irratic idle for a few seconds.
2) Loads of blue smoke out the back, smelling of unburnt diesel.
3) Smoke clears after a 3-4 minute drive, but hunting/misfire remain.
4) No loss of power, still pulls like a train

No fault codes show up on diagnostics.

The injectors have been tested and #4, I think, has been rebuilt, and everything is good with them. The fuel system is bang on according to the Injector Crowd who looked after it.

Has anyone here had the same/similar problems or know of the fix? Aparently, so I've been told by the dealer, a local engine rebuild specialist thinks it's a bent conrod! Luckily it's under warranty, but I think these fellas are trying to fool me by telling it me it was this or that, yet nothing seems to have solved the problem:censored:.

Note: Before I got the car, the Turbo was rebuilt. I'm also not sure if this is the 200 or 210 BHP engine, as I've heard that the 200 BHP engine suffers from worn valve guides/seats? Am I correct?

Any help appreciated! :)
 

·
Registered
Joined
·
1,054 Posts
If everything checks out it sounds to me like it just has a really ****ty map on it....maybe the previous owner put a cheap crap map on it. You can get a MPPS ecu reader (and writer) from ebay for less than a tenner. Maybe read the map and send it to a tuner....they will probably be able to tell you if its a stock map...and if it isn't they can iron/even out (and maybe improve) the map....and that should clear the stutter and things if this is the case.

Mind had a stuttery misfirey awful start (with a previous remap) but its totally cured with my new better map :)
 

·
Registered
2010 159 2.0JTDm Ti
Joined
·
38 Posts
Discussion Starter #5
If everything checks out it sounds to me like it just has a really ****ty map on it....maybe the previous owner put a cheap crap map on it. You can get a MPPS ecu reader (and writer) from ebay for less than a tenner. Maybe read the map and send it to a tuner....they will probably be able to tell you if its a stock map...and if it isn't they can iron/even out (and maybe improve) the map....and that should clear the stutter and things if this is the case.

Mind had a stuttery misfirey awful start (with a previous remap) but its totally cured with my new better map :)
As far as I know, the swirl flaps have not been checked. Isn't that a cambelt off job to do?

Regarding the map, this car is an import. It was brought over from England to Ireland (where I live) about 2 months ago, so I'm unsure if there's a map on it. It doesn't seem like there is though, as it doesn't appear to have any extra grunt?
 

·
Registered
Joined
·
1,054 Posts
As far as I know, the swirl flaps have not been checked. Isn't that a cambelt off job to do?

Regarding the map, this car is an import. It was brought over from England to Ireland (where I live) about 2 months ago, so I'm unsure if there's a map on it. It doesn't seem like there is though, as it doesn't appear to have any extra grunt?
well when I bought mine I didn't know it already had a map on it, but then I didn't have previous alfa experience to judge it against. It certainly isn't against the realm of possibility that it's had one given how common that kind of thing is. worth a look if nothing seems to fix it. I'm not suggesting at all that a remap is bad for engine running, quite the opposite in fact, just that a cheap or generic one could well be :)

Swirl flaps can be checked from outside top the engine, at least so far as inspecting the tops of them (I think 50p piece size objects connected by control rod) forward of the glow plugs, to see if there is any oily residue. however, i might be talking out my arse.

if the MAF, fuel and air filters, injectors (mechanically and electrically) sound, the fuel rail pressure sensor, swirl flaps, egr are all fine....then I can only imagine it is ECU/map related. but im not even going to pretend to be particularly mechanically competent so only take my comments for what they are, i.e. a thought :)
 

·
Registered
2010 159 2.0JTDm Ti
Joined
·
38 Posts
Discussion Starter #7
well when I bought mine I didn't know it already had a map on it, but then I didn't have previous alfa experience to judge it against. It certainly isn't against the realm of possibility that it's had one given how common that kind of thing is. worth a look if nothing seems to fix it. I'm not suggesting at all that a remap is bad for engine running, quite the opposite in fact, just that a cheap or generic one could well be :)

Swirl flaps can be checked from outside top the engine, at least so far as inspecting the tops of them (I think 50p piece size objects connected by control rod) forward of the glow plugs, to see if there is any oily residue. however, i might be talking out my arse.

if the MAF, fuel and air filters, injectors (mechanically and electrically) sound, the fuel rail pressure sensor, swirl flaps, egr are all fine....then I can only imagine it is ECU/map related. but im not even going to pretend to be particularly mechanically competent so only take my comments for what they are, i.e. a thought :)
You seem to have a very in-depth knowledge of these engines, I'll be in touch with the dealer and ask that all these be checked.

Thanks very much for your help. I'll keep the thread updated as I know more :)
 

·
Registered
Joined
·
59 Posts
I had similar issues on my 2.4. Ended up being a long process of elimination.
Main culprits can be:

?Maf and map sensors are either filthy or knackered.
?Fuel filter
?Glow plugs
?Injectors
?Swirl flaps leaking
?Glow plug ecu
?filthy soothed up inlet manifold
?software update not carried out which is specifically designed to reduce smoking. My car came from a main dealer who assured me it was up to date however it wasn't!

I ended up having to either replace, clean or remove all of these before I finally fixed the problem.
You can start with the cheaper ones like filter, plugs, plug ecu, sensor clean and hopefully get lucky before spending out on the expensive jobs.
As stated previously the map could also be an issue.

My car now runs beautifully with no smoke at all however it was an expensive process to put right.
Make sure you take it to the best injector guys you can find as I spent ages thinking my injectors were fine after having them tested just to find that 4 of the 5 were not happy and once replaced it made a difference to the car.

Good luck, hope it ends up being an easy fix.
 

·
Registered
2010 159 2.0JTDm Ti
Joined
·
38 Posts
Discussion Starter #11
Hello again everyone. Sorry I haven't replied to some of you, I've been on holidays for a week and a half :p

Update:

According to the dealer, the car is sorted. While I was away, the head was done (valve seats and machining), new head gasket was put on and Cylinder 1 and 5 conrods have been replaced.

The dealer now says that it runs beautifully, idle isn't erratic or lumpy, it doesn't misfire and there is no smoke.

I'm going to pick it up tomorrow morning, and have everything crossed that it's fixed this time.

Thanks for all the comments, they really have helped me a lot. I'll post when I have the car back and see how it is.

Until again, Bren :thumbup:
 

·
Registered
Joined
·
1,054 Posts
Hello again everyone. Sorry I haven't replied to some of you, I've been on holidays for a week and a half :p

Update:

According to the dealer, the car is sorted. While I was away, the head was done (valve seats and machining), new head gasket was put on and Cylinder 1 and 5 conrods have been replaced.

The dealer now says that it runs beautifully, idle isn't erratic or lumpy, it doesn't misfire and there is no smoke.

I'm going to pick it up tomorrow morning, and have everything crossed that it's fixed this time.

Thanks for all the comments, they really have helped me a lot. I'll post when I have the car back and see how it is.

Until again, Bren :thumbup:
Glad to hear its hopefully sorted now :) - let us know how you get on with it :D
 

·
Registered
2010 159 2.0JTDm Ti
Joined
·
38 Posts
Discussion Starter #13
UPDATE:

Well everyone, I am pleased to say the car seems to be sorted. Final comfirmation will be tomorrow morning when I start it from cold, because that's when it was at its worst.

This problem went deeper than myself or anyone else could have predicted. It turned out to be a combination of 2 slightly bent conrods and the valve seats. The valves were not closing properly causing the misfire.

Final update will be tomorrow :beer:

Thanks again folks, Bren :thumbup:
 

·
Registered
2010 159 2.0JTDm Ti
Joined
·
38 Posts
Discussion Starter #14
THIS FU**ING CAR ???

Started it from cold....

Coughing like a b*tch and spitting out blue smoke. Honestly have lost all interest in this car now. I'm sorry to say, but the good has gone out of it for me

The dealer has offered me my money back so I'm taking him up on his offer. I cannot trust that all the supposed work has been done in this car.

I can't have this hardship.

My next question is, what the bloody hell do I get next? ?

Sent from my SM-G900F using Tapatalk
 

·
Registered
Joined
·
1,054 Posts


Such a shame. It's a drop-dead gorgeous car :(

Sent from my SM-G900F using Tapatalk
Oh no :( that's awful :/....have you tried the map check route? a final hope perhaps or has the magic tarnished now?

you could start saving the pennies for a Guilia? haha. I already am :p or rather for the bigger one that comes next
 

·
Registered
2010 159 2.0JTDm Ti
Joined
·
38 Posts
Discussion Starter #17
Haven't tried the map route and tbh, I'm not going to. Good suggestion though, but I've decided she's gone.

Begod I'd love a Guilia. Such a beast of a car!

Thanks for the suggestion though! ?

Sent from my SM-G900F using Tapatalk
 

·
Registered
Joined
·
1,054 Posts
Haven't tried the map route and tbh, I'm not going to. Good suggestion though, but I've decided she's gone.

Begod I'd love a Guilia. Such a beast of a car!

Thanks for the suggestion though! ?

Sent from my SM-G900F using Tapatalk
No worries, Sorry it's turned into such a disaster for you
 

·
Registered
2010 159 2.0JTDm Ti
Joined
·
38 Posts
Discussion Starter #19
No worries, Sorry it's turned into such a disaster for you
As am I. I guess it was just a bad one. Sure look, it happens to the best of us. But don't you worry, I'm be back in an Alfa yet. They're like drugs and I'm hooked, have been since my 156 2.0 TS ;)

Sent from my SM-G900F using Tapatalk
 
1 - 19 of 19 Posts
Top