Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
157 Posts
Discussion Starter #1
Hello everyone, I have a problem with my Brera, the engine revs very very slowly until around 2000rpm, after that it goes normally, pulls as it was new, but below 2000 it is extremely sluggish, I even had trouble getting out of my garage because the exit ramp is upwards.

I have read many posts about the EGR and swirl valves, but my problem is stranger because It didn't degrade slowly. I went for a drive, everything was ok. I parked the car, and when I went for another drive the problem started as soon as I turned it on, it came suddenly.

Does anyone have an idea of what it could be? My car has 72 000Km, and never gave me any problems, this is my first one and I'm very worried :(

Thanks,
Tiago
 

·
Registered
Joined
·
119 Posts
EGR valve.

I've just had the same problem. I removed the EGR valve, cleaned out the masses of soot, and eventually got the solenoid moving freely. I also installed a blanking plate with a hole in it.
The low rev problem seems to be cured (although I think it could still be better), but I now have a "check engine" light. I think this is caused by the blanking plate.
My next plan is to fit a full blanking plate and have the EGR deleted. This will happen on Wednesday. Fingers crossed.
 

·
Registered
Joined
·
86 Posts
Agree EGR valve. I have recently had same issue. No degradation in the problem. fine one day then not the next. same symptoms. New EGR valve and the reduced flow plate and back to normal.

Good luck with a fix.
 
1 - 3 of 3 Posts
Top