Alfa Romeo Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter · #1 · (Edited)
Hi Guy's

I just recently bought an Alfa 156, 2.0ltr, 16v, Selespeed, and am absolutely loving it. However the garage I bought it from cannot help with the radio unlock code.
Please is the anyone out there can help me.

The radio model/serial number, is 815 BP331147070108

The part number is 7643 311 316

Please, please help me with a radio unlock code.

Also about a week ago my Alfa just konked out on me. Parked outside a shopping centre and it just would not start. It just makes a click sound when ignition key is turned. I tried a new battery, still just clicks. Had alfa mechanic over with diagnostic tester and all tests OK. Could it be the starter itself????

Your help please!!!!!!
 

·
Registered
Joined
·
2,269 Posts
I think there is a thread for radio codes, search? You need a multimeter to test the battery after a run. Could be alternator or something draining it (lights, 12V, lighter...)
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #3 ·
Thanks, puller starter out. Brushes shot. Repairing now, should be back on the raod in a couple of hours!!!!!
 

·
Registered
Joined
·
16 Posts
I have a similar model with Selespeed. I didn't realise that it won't start unless in Neutral. You need to press the brake pedal down to do this with ignition on.
I also love this car.
 

·
Registered
Joined
·
145 Posts
Discussion Starter · #5 ·
Thanks guys.
It was the starter after all. Bit of a hassle to get out. You really have to get your hand in there.
The brushes worn down to almost nothing. Had these replaced, cleaned out commentator on armature, reassembled, stuck it back into the car and wahllah. My Bella is back on the road and purrrrrrrrring like a cat!!!!!
 
1 - 5 of 5 Posts
Top