Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi everyone its my first post and in need of some help... I recently purchased my first european car of course being this little alfa. Anyway recently I tried to start it and it would turn over easily but wouldnt fire! It was more suprising as I have had no indication of it happening as I was driving it fine the night before. I have gone through these threads and sounds like alot of people have similar problems but going by what people have advised mine seems to be more unusual. So far I have checked the kill swith below the passenger side I have checked the fuel lines and the one that goes to the top rear of the engine (black tube) seems to be really dry and i suspect that it may be blocked? If so how would I unblock it? The fuel pump was replaced about a month ago and it has a full tank of fuel. If anyone has any ideas then please feel free to give me a reccomendation as im sure most of you would know a hell of alot more then me lol. Ill try to add a pic of what im sure is a fuel line but im no mechanic =\ Thank you in advance. Rich
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Its more likely that the pump isnt priming (coming on when you turn the key). if you can lower the rear arm reset and open the ski tunnel hatch this will allow you to hear the fuel pump priming when you turn the ignition key.
Ok so the rear arm rest you mean the back seat rest? And the ski tunnel you mean the passage behind it that leads to the boot? Sorry you will have to dumb it down a bit lol no idea what that is.. when i turn the key it sounds like its working..well its doing something (sounds like a pool pump) with other cars i know if its not working you hear a buzzing sound and would kick the tank to make it work. Cheers =]
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hi Ive heard about the code light from other threads and tried it but no theres no code light at all =\ Thanks
 

·
Registered
Joined
·
30,018 Posts
You should be able to hear the fuel pump without lowering anything.

But as you've a Selespeed you need to make sure you are listening to the Fuel Pump and not the Selespeed Pump.
They sound different and come from opposite ends of the car, so easy to tell apart.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
You should be able to hear the fuel pump without lowering anything.

But as you've a Selespeed you need to make sure you are listening to the Fuel Pump and not the Selespeed Pump.
They sound different and come from opposite ends of the car, so easy to tell apart.
Yeah its deffinetly the fuel pump I can hear as im listening at the back of the car... is it normal to sound similar to a swimming pool pump (probably the best way I can describe it)?
 

·
Registered
Joined
·
2,613 Posts
Keep your eyes peeled - it's in the little display between speedo and rev counter. Bottom right of the screen. It's a key symbol with the word CODE in tiny letters. Only on for half a second or so when you first turn the key.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9 (Edited)
I just tried it and the only thing that comes up for a second is a picture of the front of the car (symbol) with a padlock in front of it...could that be it? I attached a photo its in the center and bottom right corner..
 

Attachments

1 - 9 of 9 Posts
Top