Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1 (Edited)
Well this is a little embaressing :)
first ever post *gulps*

Well i believe i have now officially been alferised!!

just bought a 2001 alfa romeo 156 1.8 veroce today! forgot to mention its a t-spark!!!!
Well what can i say shes lovely but in true alfa romeo style....

half way home..yes halfway i didnt actually make it home for another 2 hours lol :p
we had some seriously warm engine problems to be well vague i suppose.
so half way home popped the hood to find lots of steam coming from the expansion tank and temoerature gauge very red and very hot water everywhere lol...

i know enough about mechanics but this is true alfarisation lol.

the engine cooling fan is not kicking in at any point from what i gather i believe the fan should kick in at 90 degrees or 93 summit like that but we have nothing....not even when she hit the red light !!!

so thats problem number 1.

also the interior heater blower isnt working air con light works and all lights work fine but just does not blow anything at all so was a bit :( lol....but im sure all you nice people here can guide me the right way.

taken it too my local mechanic who sais it coulkd simply be a relay or a fuse or bad circulation etc....

and last but not least for now lol is the rear electric windows....well simple as it is they dont work !!

any tips or hints would be greatly appreciated

many thanks

Daniel


------------------------------------------------------------------------------

WELL ITS AN ALFA . . . . PURCHASED AT 1:39PM ON THE 3/2/2010
BONNETT OPEN AT 2:11PM ON THE 3/2/2010


TRUE ALFA-RIS-ATION !!

------------------------------------------------------------------------------
 

·
Registered
Joined
·
5,266 Posts
Unless you are stuck in traffic i'd be supprised if the fan would even come on in this kind of weather. So i'd rule that out and start looking at blocked rads, low coolant level, possible head gasket problems.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #5
Thanks for all help, going to have it apart today and see if i cant find out whats wrong with it. with any luck the engine fan or something silly will be the cause of the overheating. the interior blower i have a feeling may b one of the relays but again will have it all out today and check it over. i mean no1 likes to be out in the cold with no heater :p thanks x
 
1

·
Guest
Joined
·
0 Posts
Thanks for all help, going to have it apart today and see if i cant find out whats wrong with it. with any luck the engine fan or something silly will be the cause of the overheating. the interior blower i have a feeling may b one of the relays but again will have it all out today and check it over. i mean no1 likes to be out in the cold with no heater :p thanks x
if its overheating it could be the resistor in the fan that has given up the ghost not allowing the fan to cut in, also change the relay this cured the problem for me.

parts are off the shelf from alfa
 

·
Registered
Joined
·
21 Posts
Discussion Starter #8
Yeah i have heard a bit about the resister and fuses going fairly often . . . i believe it is located on top the fan isnt it? thanks :)
the fan is not cutting in at any point at all . . . like i said not even at 110+!! there is nothing at all !!

x
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
are you sure its new window mechanisms? due to them being electric rears? perhaps another electrical fault???
 

·
Registered
Joined
·
6,811 Posts
are you sure its new window mechanisms? due to them being electric rears? perhaps another electrical fault???
if the lights are on in the doors, and the relay clicks when the button is pressed, then its seized motors, and the mechanism needs replacing. in any case they share a fuse with the fronts i believe.

it is very common, my passenger side rear doesnt work:lol:
 

·
Registered
Joined
·
21 Posts
Discussion Starter #11
there is no clicking u press the button and nothing !

UPDATE:

car has been assessed...

she needs a new rad, new fan switch and new thermostat for the grand total of £300 is that good or bad lol?
 

·
Registered
Joined
·
21 Posts
Discussion Starter #12
haha just another perk of owning an alfa !! ure poor window. what ever happened to good old grow ure muscle window winders lol
 

·
Registered
Joined
·
5,266 Posts
Rad £55 off Ebay, stat about £30 from Shop4Parts, no idea on the fan switch i'm afraid (assuming you are talking about the heater fan). Figure in what you like for labour if you can't do it yourself. £300 from a dealer is about right i would say (assuming it includes VAT as well though)
 

·
Registered
Joined
·
21 Posts
Discussion Starter #14
yeah he is going to do the thermostat and fan switch for now and he said a bit of rad weld will be ok for a couple 100 miles and going to do rad myself get the part from ebay :)

do you guys rate rad weld just for a temp fix?

and yes its the fan blower switch but he is going to do stat and switch labour for 20 quid :)
 

·
Registered
Joined
·
5,266 Posts
Just keep an eye on the temp gauge, if it starts to go skywards then stop the car becasue overheating will kill it very quickly!
 

·
Registered
Joined
·
21 Posts
Discussion Starter #16
thank you :) all help is greatly appreciated.
went to change thermostat today and autoquip sent bloody wrong one with no gasket on it :(
and they sent a new heater control switch which also was the wrong one!
:mad: :mad: :mad:

i think monkeys have taken over autoquip !!
 
1 - 16 of 16 Posts
Top