Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
255 Posts
Discussion Starter #1
Put shiny bolt to show where hole is in photo.
Had oil dribbling past the bolt and always thought it was exhaust manifold stud - but it isn't. I tried tightening it and it's just spinning - made it worse because it's now dripping oil straight onto the exhaust! What is it please and how do i fix it???? Thanks
 

Attachments

·
Registered
Joined
·
6,004 Posts
That is the strengthening mount point for the water bypass channel from the thermostat back to the block water inlet.

Oil should not be be seeping out from there - The bolt that should go in there is quite short. I think someone screwed a too long bolt in there and might have cut into the block wall, into a oil channel. To be honest The water bypass channel is quite strong enough to carry its own weight. I'd clean out that hole as properly as possible and seal it with Pratley's Steel. You can try it without removing the exhaust, or you might need to remove it, to remove the carrier stub
 

·
Registered
Joined
·
255 Posts
Discussion Starter #3
That is the strengthening mount point for the water bypass channel from the thermostat back to the block water inlet.

Oil should not be be seeping out from there - The bolt that should go in there is quite short. I think someone screwed a too long bolt in there and might have cut into the block wall, into a oil channel. To be honest The water bypass channel is quite strong enough to carry its own weight. I'd clean out that hole as properly as possible and seal it with Pratley's Steel. You can try it without removing the exhaust, or you might need to remove it, to remove the carrier stub
That's worrying! I thought it was odd that it had an exhaust manifold stud in it (replacement engine)
I've managed to helicoil and fit a short M8 bolt - fingers crossed!
Thanks
 
1 - 3 of 3 Posts
Top