Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter #1
Anyone knows the lifespan of these alternators? Are they the same as the Selespeed models.

Mine's giving problems. The noticeable symptoms are the speedos not working when more electricals are turned on e.g. climate control, sound system etc. Then there's the rpm increasing on idle when the car is slow in a traffic jam.

Now, are these buggers serviceable?

The V6 is rumoured to consume more amps than the Selespeed. Is that right? Heard of conversions to Merc alternators with outputs higher than 120 Amps.

It's still charging slightly at 12.5 Volts although for how long, I don't know. Ideally it should be 13.8Volts, correct me if I got it wrong.

Bummer!


Low on Volts
 

·
Registered
Joined
·
49 Posts
Discussion Starter #3
Focus! Focus!

Ex-girlfriend, now my avatar! On the internet too.

More, only if I get my answers!
 

·
Registered
Joined
·
3,806 Posts
Sure that isn't just a cell in the battery gone? What is the voltage on the battery when the engine is off?

BTW, I`m over 211,000 miles on my alternator without a problem so far.
 

·
Registered
Joined
·
49 Posts
Discussion Starter #6
I gotta change that Avatar! No, the battery is new and measuring around 12.5V with the engine off.

Then again I live in very hot and humid weather. Makes alternators age faster, but my skin looks great!
 

·
Registered
Joined
·
472 Posts
kenneth im malaysian, too. ill tell u a good cheap place to fix ur alternator if u intro me to ur ex-gf. :D

just kidding. i had the same symptoms as u before. the rpms rise when the car is idling due to insufficient voltage. the ECU compensates by upping the rpms. damn annoying.

there are ways to recond the alt, or frankenstein other cheaper alts into our housing (like what i did). the original alfa/bosch alts are too hard to find and too expensive here.

give me a call, we'll sort you out.

redd - 012-3774191
 
1 - 7 of 7 Posts
Top