Alfa Romeo Forum banner

2.4 jtdm injector data

2651 11
Hi guys,

To briefly sum up I've been having a engine judder with a spike in RPM at idle when the car reaches water temp 90degC and not a degree less, not even at 89. Inlet Manifold replaced/ EGR replaced/ MAF unplugged/ MAP cleans/ Air duct to turbo tightened/ DPF = Normal clogging & no fault codes. Still no difference. For anybody who is interested in detailed trouble I've been having see this thread...

http://www.alfaowner.com/Forum/alfa-159-brera-and-946-spider/381986-are-my-issues-related.html

It has got worse in the heat and the other day I had a scary juddering at 70mph, 2000rpm in 6th gear. This has happened once before after the manifold was replaced but I thought it was a DPF regen.

I've taken some data using ECU scan and an excel spread sheet. I've monitored the injectors and I wondered if any tech'ies can interpret the data....

Below is a graph taken seconds after start up...

Text Line Parallel Diagram Slope


This one shows the injectors seconds after I watched the water temp sensor gauge reach 90degC. It was accompanied by juddering, and a repeated increase and decrease in RPM. Injector 4 seems interesting

Text Line Font Parallel Plot


I have the free version of ECUscan so I can only monitor 4 injectors (parameters) at a time. (plus I forgot to save the other 2 graphs. :rolleyes:

However I did take this data at warm:

Injector Cyl. 1: minimum reading -52mm3/i to max reading -32mm3/i
Cyl. 2: min -36 to max -22
Cyl. 3: min -0.99 to max -75
Cyl. 4: min +2.54 to max +2.72
Cyl. 5 min -82 to max-68

Can anybody interpret what these readings say about the state of my injectors? Particularly Injector 4 which gave a plus 2.5 - 2.7 reading when all the others read between 0 and minus 1.

Would this be causing the symptoms I am experiencing?

Do any need replacing/ reprogramming/ reconditioning?

I would appreciate any views.
1 - 3 of 3 Posts

· Registered
Joined
·
1,770 Posts
certainly be interesting to see if this cures the dodgy 90 deg c issue.
i can see injector issue giving a lumpy idle yes ,but whats going on at 90 i cant get my head around.
i lookeed through the maps(all i could find) after reading in your other threads but all i could find that would be affected by temp was fuelling / engine temp limiter and this would only limit max fueling (i think it was around 70mm3 at 90 deg idle speed)not the sort of iq required on idle which is more like 5-10mm3
hope it sorts it, if it doesnt no doubt when it hits 90 the amount of lumpyness will be reduced with injector sorted.
 

· Registered
Joined
·
1,770 Posts
i find letting it tick over on its own shows variation in injectors more, as it is being revved the speed is increased and the ability to sense variations in rotational crank speed much less i would think.
mine would always go from just over or just under 1 at idle to very close to .2 to vero when revved.
bear in mind thats all the injector correction is doing trying to give an even crank speed on all strokes
if it doesnt get any better with injector sorted you may be looking at valves or piston rings or head gasket issue on that cylinder maybe worse case, not read any similar issues so i hope its not.
 

· Registered
Joined
·
1,770 Posts
check that they swapped the injectorcodes to match by checking in fes.
look for the 8 unit code i think on the top of the solenoid and compare with data from fes, if they havnt switched the codes round i think you can do it(unless its only paid version)
but codes and injectors have to match or running will be as bad as before
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top