Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
231 Posts
Discussion Starter #1
Hi guys,

To briefly sum up I've been having a engine judder with a spike in RPM at idle when the car reaches water temp 90degC and not a degree less, not even at 89. Inlet Manifold replaced/ EGR replaced/ MAF unplugged/ MAP cleans/ Air duct to turbo tightened/ DPF = Normal clogging & no fault codes. Still no difference. For anybody who is interested in detailed trouble I've been having see this thread...

http://www.alfaowner.com/Forum/alfa-159-brera-and-946-spider/381986-are-my-issues-related.html

It has got worse in the heat and the other day I had a scary juddering at 70mph, 2000rpm in 6th gear. This has happened once before after the manifold was replaced but I thought it was a DPF regen.

I've taken some data using ECU scan and an excel spread sheet. I've monitored the injectors and I wondered if any tech'ies can interpret the data....

Below is a graph taken seconds after start up...

Injectors  - Cold - 08.07.2013.png

This one shows the injectors seconds after I watched the water temp sensor gauge reach 90degC. It was accompanied by juddering, and a repeated increase and decrease in RPM. Injector 4 seems interesting

Injectors  - Warm - 08.07.2013.png

I have the free version of ECUscan so I can only monitor 4 injectors (parameters) at a time. (plus I forgot to save the other 2 graphs. :rolleyes:

However I did take this data at warm:

Injector Cyl. 1: minimum reading -52mm3/i to max reading -32mm3/i
Cyl. 2: min -36 to max -22
Cyl. 3: min -0.99 to max -75
Cyl. 4: min +2.54 to max +2.72
Cyl. 5 min -82 to max-68

Can anybody interpret what these readings say about the state of my injectors? Particularly Injector 4 which gave a plus 2.5 - 2.7 reading when all the others read between 0 and minus 1.

Would this be causing the symptoms I am experiencing?

Do any need replacing/ reprogramming/ reconditioning?

I would appreciate any views.
 

·
Registered
Joined
·
231 Posts
Discussion Starter #2
Been to Motormech & had it confirmed that injector 4 is massively out and needs replacing.
 

·
Registered
Joined
·
1,768 Posts
certainly be interesting to see if this cures the dodgy 90 deg c issue.
i can see injector issue giving a lumpy idle yes ,but whats going on at 90 i cant get my head around.
i lookeed through the maps(all i could find) after reading in your other threads but all i could find that would be affected by temp was fuelling / engine temp limiter and this would only limit max fueling (i think it was around 70mm3 at 90 deg idle speed)not the sort of iq required on idle which is more like 5-10mm3
hope it sorts it, if it doesnt no doubt when it hits 90 the amount of lumpyness will be reduced with injector sorted.
 

·
Registered
Joined
·
231 Posts
Discussion Starter #4
Thanks for the reply sussexa & for looking in to the maps for me.

I have data recorded of the injectors at 2000rpm from cold start & at 90degC. I haven't had much laptop time to convert them to graphs as of yet but injector 4 doesn't change from cold. However it does comes back in to line with the others when holding the car at 2000rpm. Strange.

I really hope that by replacing the injector the issue is sorted.

On the bright side this is not a exclusively Alfa issue. Today I drove works 12 plate, diesel Ford Kuga with 40k on the clock and it did the same thing! Although the only evident common denominator at the moment is me! :rolleyes:
 

·
Registered
Joined
·
1,768 Posts
i find letting it tick over on its own shows variation in injectors more, as it is being revved the speed is increased and the ability to sense variations in rotational crank speed much less i would think.
mine would always go from just over or just under 1 at idle to very close to .2 to vero when revved.
bear in mind thats all the injector correction is doing trying to give an even crank speed on all strokes
if it doesnt get any better with injector sorted you may be looking at valves or piston rings or head gasket issue on that cylinder maybe worse case, not read any similar issues so i hope its not.
 

·
Registered
Joined
·
231 Posts
Discussion Starter #6
if it doesnt get any better with injector sorted you may be looking at valves or piston rings or head gasket issue on that cylinder maybe worse case, not read any similar issues so i hope its not.
Number 4 & 5 injectors were swapped by Motormech. Now number 5 (was number 4) injector is playing up.

To be honest I fear those things listed above. How do they fail & how would I diagnose them?

If it's not the injector then I may have to question the longevity of the car and whether it is financially viable to keep it and replace those parts. Sad really because I do love it when it's on form.


Sent from AutoGuide.com App
 

·
Registered
Joined
·
1,768 Posts
check that they swapped the injectorcodes to match by checking in fes.
look for the 8 unit code i think on the top of the solenoid and compare with data from fes, if they havnt switched the codes round i think you can do it(unless its only paid version)
but codes and injectors have to match or running will be as bad as before
 

·
Registered
Joined
·
135 Posts
Having had the same problems .... Have had EGR replaced / injectors / manifold / etc etc .....

My cars fault was diagnosed as the cylinder head ( not under warranty ) ....

I was in the same boat as you until today mate then finally got it sorted once and for all .... ....Bought a new car ....

Good luck mate .
 

·
Registered
Joined
·
135 Posts
Hello SP36 ...

I hope your getting yours sorted mate ...

Mine smokes on start up ...then judders a lot .( almost stalls ) .. After a couple of heavy revs its ok ... Then a few miles in it judders again and holds back ... Not all the time though but on an average 25 mile commute its enough to drive me mad .....

The dealer- Alfa uk - and warranty company have refused to do the head ( even after admitting its a fault ) but as a compromise ( good will ) are doing a de-coke ...

Its booked in for the 14th August for 2 weeks ??? Head off .. Valves out - cam belt - tensioners - head gasket ..... Then old head back on ..... They said its only a matter of time before it ' soots' up again as its the head that's at fault ( there's a new upgrade now ) .....

I've given up mate ..... After all the work ... Countless trips to the dealers ... I've finally bought a new car .... Due in September .... I'm getting the work done ,so hopefully the person that buys it next will have some luck with it even if it is for a short while ......

Keep me posted as Id be interested in hearing your outcome and hope its better than mine ..
 

·
Registered
Joined
·
231 Posts
Discussion Starter #11
Cheers Bre,

I hand an injector replaced today and initially it seems that has gone a long way to resolving the issue. It is there but drastically reduced to a point you would not notice unless you were looking. If it stays this way then I am happy. Power delivery is smoother, gear changes from 1st to 2nd seem better, and the car is much quieter not sounding so much like a tractor.

I understand you troubles, and although you seem to have bigger problems, mine has come out of my own wallet. I am considering getting rid of the car while the going is good as I have lost some confidence in it. Especially as the main car for a young family!

Just out of interest, what is your replacement?
 

·
Registered
Joined
·
135 Posts
Hello SP36 ....

I'm glad to hear that you have improved the issues with the injector replacement ... Hopefully you will get some faith back in your car .....when mine were done I was over the moon with the difference .....I tried the better fuel and ' hard drive ' technique and to be fare it did help as well ( not on fuel economy though ! ).... Then the other issues started and my confidence slipped again .......

Hopefully yours will be ok now but I know the dilemma your in ...chop it in whilst the goings good or persevere and hope for the best ?! ....

Mines not even done 40k and its literally falling apart around my ears ! ...

I tried a few cars and narrowed it down Either a new scirocco 2.0 tdci or a Kia1.7cdi sportage ... After head scratching and test drives and plenty of research I decided on the kia ..(impressed with the warranty - mpg - service costs -spec as standard - running costs - etc etc ....

Ok it's not going to turn the heads like my Brera ... Its not going to go like the Brera ...its not going to make me smile as much as the Brera ... I probably won't look back at it when I get out off it....But its hopefully going to be More reliable .....

Would I buy another Alfa ............... Not a chance .

Good luck mate .
 
1 - 12 of 12 Posts
Top