Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
167 Posts
Discussion Starter #1
ok 2 problems

Just got alfa diag and cleared all errors in the ecu to be sure i was only reading current stuff

cleared codes and car went like s*** off a shovel - i am not sure if this thing has already been remapped or not...

anyway on hard accel in 3rd at about 3k rpm got engine management light flash up for a second motor control failure and acceleration died. let off throttle and then it accelerated again but felt way more ponderous

got 2 error codes
p0380 - dodgy glow plug - don't care - unless its minus 14 it'll be fine
p0235 - this one concerned me turbo system overboost

I am also getting VDC system fail on MAR straight away before engine start.

I had the same thing on my seat leon cupra 1.8t and that was a failed maf sensor which took the traction control offline immediately - was thinking along the same lines with this one hopefully.

I was getting VDC errors on and off as usual in the cold weather but since i reset the ecu it's now on from start.

any ideas guys? Am i along the right lines?
 

·
Registered
Joined
·
167 Posts
Discussion Starter #3 (Edited)
The VDC could be the fuse
Error could be MAP sensor or Blocked EGR
thanks :)

Which fuse? where is it? and why would it blow? :lol: **edit** just found another thread about the midi fuse - i only have the VDC faule - abs light goes out and is fine

i'll have a look at cleaning the MAP

*** Edit 2 ***

place i bought the car from had the tracking done but the steering wheel is off center although drives fine

would this upset the steering angle sensor thingy?

just wierd how it would be ok ok for 2 weeks then suddenly kick up a fuss.

wheel is at about 11:00 when driving straight
 

·
Registered
Joined
·
9,912 Posts
MAP

*** Edit 2 ***

place i bought the car from had the tracking done but the steering wheel is off center although drives fine

would this upset the steering angle sensor thingy?

just wierd how it would be ok ok for 2 weeks then suddenly kick up a fuss.

wheel is at about 11:00 when driving straight[/QUOTE]

,take it back and ask them to job properly:thumbs:
 

·
Registered
Joined
·
167 Posts
Discussion Starter #6
MAP

*** Edit 2 ***

place i bought the car from had the tracking done but the steering wheel is off center although drives fine

would this upset the steering angle sensor thingy?

just wierd how it would be ok ok for 2 weeks then suddenly kick up a fuss.

wheel is at about 11:00 when driving straight
,take it back and ask them to job properly:thumbs:[/QUOTE]


garage is 180 miles away :lol:
 

·
Registered
Joined
·
167 Posts
Discussion Starter #7
OK not the fuse, think its the batt

after i have been driving for a while i can stop and start the engine and it goes away - if its been stood a while its on straight away
 

·
Registered
Joined
·
167 Posts
Discussion Starter #8
cleaned map and all seemed ok but got the error on hard acceleration - definately better for cleaning the maf though, was caked in carbon deposits !
 

·
Registered
Joined
·
167 Posts
Discussion Starter #12
No not yet - next job - or i'll block it off - can it be disabled through alfa diag do you know?
 
1 - 12 of 12 Posts
Top