Alfa Romeo Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
41 Posts
Discussion Starter #1
Hi All

I am looking to replace my 2.4 20V mjet turbo as I believe the vanes are sticking ?

I am going to to strip it out ad clean it at the weekend.

I am not hopeful :(

Therefore my question is mine is an 05 plate are the turbos all the same on the 20V mjets ?

and how much Am i LOOKING AT FOR FOR A RECON / EXCHANGE UNIT ?

thanks Andy
 

·
Registered
Joined
·
822 Posts
In my file of "companies I might need sometime" is Midland Turbo in Nottingham. Thus, someone muct have recommended these people on this forum.

Home | Midland Turbo

My understanding is that the 20v should all be the same.

Keith
 

·
Registered
Joined
·
1,928 Posts
itll clean up nicely dont worry
wouldnt think of spending dosh just yet.........except on new actuator pipe, u may as well do that too

Gary
 

·
Registered
Joined
·
41 Posts
Discussion Starter #5
I am getting it re conned by a specialist with new bearings etc and then checked etc

just got to get it off this weekend!
 

·
Registered
Joined
·
98 Posts
In my file of "companies I might need sometime" is Midland Turbo in Nottingham. Thus, someone muct have recommended these people on this forum.

Home | Midland Turbo

My understanding is that the 20v should all be the same.

Keith
I've used these on some pretty unusual turbos. They always seem genuinely interested and go out of their way to help wherever possible....without really charging anything out of the ordinary.

In the top 10 of companies I've dealt with. :)
 

·
Registered
Joined
·
41 Posts
Discussion Starter #10
now I now why the boost was so low from my howling turbo !
the exhaust impeller has disintegrated and taken out he VNT mechanism OMG
New turbo required
How much !!
 

·
Registered
Joined
·
855 Posts
I've used midland turbos - happy with result. A year on and still going strong. They thought it was impact damage to my turbo, but got it fixed 560 inc vat.
 

·
Registered
Joined
·
1,928 Posts
now I now why the boost was so low from my howling turbo !
the exhaust impeller has disintegrated and taken out he VNT mechanism OMG
New turbo required
How much !!
more to the point where have all the bits gone?? u never said it whistled thats sign of damaged turbine impeller !

Gary
 

·
Registered
Joined
·
41 Posts
Discussion Starter #15
update

New turbo installed all fixed ! however still doesn't feel as boosty as my previous trusty 10V :(
 

·
Registered
Joined
·
822 Posts
Might be worth plugging in the diagnostics and seeing what PSI you are getting on full boost? I would have thought it should feel a fair bit quicker than a 10V!

Keith
 

·
Registered
Joined
·
41 Posts
Discussion Starter #18
Hi there

its getting better i have done 125 miles now ! maybe the ECU is still learning !

more worryingly the previous owner had put 6.5 litres of gearbox oil in so swapped it with 2.4litres as GM forums suggest no more overheating clutch release bearing and sweet gearbox now
I am warming to her !
 
1 - 18 of 18 Posts
Top