Alfa Romeo Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter · #1 ·
Hi!

I was driving and suddenly an error appeared in my dashboard.

Using ALFA OBD with an Android smartphone I had this advices. So I supose that something is wrong with Lambda 1 wich is under the cover of the engine, Am I right?

It seems a wire broken or a short circuit in the sensor but could it be another reason?

Has someone any experience on this?

Thanks.
 

Attachments

·
Registered
Joined
·
671 Posts

·
Registered
Alfa 159 2.0 JTDm Lusso 6sp.
Joined
·
7,284 Posts
Is screwed into the top of the the DPF under the bonnet...no need to remove engine cover. Same happened to mine...was broken wire on the loom side of the connector...typical (the heat hardens them and they snap). Soldering iron and heat shrink sorted it.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #4 ·

·
Registered
Joined
·
58 Posts
Discussion Starter · #5 ·
Is screwed into the top of the the DPF under the bonnet...no need to remove engine cover. Same happened to mine...was broken wire on the loom side of the connector...typical (the heat hardens them and they snap). Soldering iron and heat shrink sorted it.

Is this the lambda 1? Really? Is not this which I´ve attached? Thanks
 

Attachments

·
Registered
Alfa 159 2.0 JTDm Lusso 6sp.
Joined
·
7,284 Posts
Yep..is just a basic oxygen sensor in the JTDm models.
 

·
Registered
Joined
·
671 Posts
The one one the photo you took from another forum doesn’t look like the same engine as in mine (939B3000).

It is sitting below the heat shields as explained in the posts I referred to previously. Lambda sensors of this special kind are always facing to the floor.
 

·
Registered
Alfa 159 2.0 JTDm Lusso 6sp.
Joined
·
7,284 Posts
That is the one...the heat upper shield (there are two) has been removed in that pic....you can see the bolt holes. You need to remove both to actually unscrew the sensor.
 

·
Registered
Alfa 159 2.0 JTDm Lusso 6sp.
Joined
·
7,284 Posts
I see what you are saying....I thought is was just the angle the photo was taken at. Mine looks just the same as yours....on top of the DPF.....but the two layer heat shields look exactly the same is the OPs pics.
 

·
Registered
Joined
·
58 Posts
Discussion Starter · #11 ·
The one one the photo you took from another forum doesn’t look like the same engine as in mine (939B3000).

It is sitting below the heat shields as explained in the posts I referred to previously. Lambda sensors of this special kind are always facing to the floor.
I haven´t disambled both heat covers only the small one, and it seems quite similar to the picture. But it could be the same as yours because my engine is 2.0 jtdm 136hp and the engine code is almost the same 939B4000. The important thing is to know of which sensor we´re talking about, and for a while it´s clear is somewhere in the exhaust pipes, under the heat covers. :cheeky:
 
1 - 11 of 11 Posts
Top