Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
58 Posts
Discussion Starter #1
Hello All
Just picked up my 147jtd lusso multi 2005 facelift model experience so far is mixed. I bought it private with 70k miles and full documented svc history. My issues are
The guy I bought the car from said that on occasion the Air bag light will come on then go off, all the way home today it was on my experience with Air bag lights is once on they have to be reset by dealer/workshop coder. The history shows there was a issue here relating to the seatbelt pre-tensioner had a loose connection and was repaired with a cable tie:confused::lol:
Next the Cruise control on would not iluminate so assume it was not turned on tried it again hour later and the light on the dash came on:confused: Maybe i am doing somthing wrong or again poor connection somwhere?
Finally reading the history showed that at 52k two years ago the cam belt broke and took out a few valves and followers:eek: work was all carried out at a huge cost but my question is are there other things that I should be aware of and check etc albeit it has been 20k miles ago. Will be getting the belt replaced at about 90k alloowing the belt 40k miles i think.
Any advice would be appreciated & sorry if I should have posted into the tec section. :thumbs:
 

·
Registered
Joined
·
1,563 Posts
The airbag light is probably due to the cable under the seat and I know on the 2002+ model of the 156 it would autoreset unlike the early versions, expect the 2005 147 is the same.

Cruise control, you need to turn the little switch on the left so the light comes on, then hit the stalk up from memory and it will then lock the speed. If temperamental then either the pedal switch isn't allowing the system to engage or the main stalk.

Cambelts are every 36k or 3 years (whatever comes first) :thumbs:
 

·
Registered
Joined
·
58 Posts
Discussion Starter #3
Hey thanks for that I do need to me investigations so may need to get on the teccy site.
Nice to know that other folk are they to help :)
 

·
Registered
Joined
·
13,233 Posts
If you're at 70k, then I'd really do the cam-belt/tensioner/pulleys and water pump at 72k, so it stays on the 36k intervals.

Don't worry about the cam-belt... if you were going to have any "afters", the beast would have thrown a wobbly by now. Normally the bearing shells get flatted if the engine suddenly locks up but if it's all quiet down there, they'll probably last alright now.


Ralf S.
 
1 - 4 of 4 Posts
Top