Alfa Romeo Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
hello all. i've got an annoying problem. other sites seem crap for advise. and thats wot i need. so if anyone can advize me i'd appreciate it . cheers
on top right of speedo a red light in the shape of an injector has been intermitently illuminating. when this happens it results in a loss of power. the revs seem lots more unresponsive. if anyone has encountered/overcome this i'd appreciate the advise. hope to hear from someone. cheers again.
 

·
Registered
Joined
·
43,564 Posts
Hello and Welcome !! :)
 

·
Registered
Joined
·
6,451 Posts
Welcome to AO, hope someone can assist you :)
 
M

·
Guest
Joined
·
0 Posts
webbs said:
hello all. i've got an annoying problem. other sites seem crap for advise. and thats wot i need. so if anyone can advize me i'd appreciate it . cheers
on top right of speedo a red light in the shape of an injector has been intermitently illuminating. when this happens it results in a loss of power. the revs seem lots more unresponsive. if anyone has encountered/overcome this i'd appreciate the advise. hope to hear from someone. cheers again.
welcome to AO dude....

could be a few things....dodgy Lambda sensor or a knackered MAF (Air Flow Meter)....

neither will cause damage to your engine, rather reduce power and increase fuel consumption...

you could always try and give the MAF a clean..

Remove the MAF - undo the metal clips with a pair of small pliers or lever off with small screwdriver, undo the cable tie which keeps the connector cable tidy to the air duct.and then the connector remove the MAF.

There are 2 TX secrurits screws that clamps the sensor to the MAF body...these can be undone with pliers as they are not to tight.

Pull the sensor head out and stick the MAF body a bowl of luke warm water and slosh about...use a sponge to clean the inside of the MAF body but do not touch the Mesh. then put back in the bowl and leave for about 20 Mins...

To clean the sensor head you need anti-static cleaner from Maplin or any radio hobby store..

Spray liberally all over the head......

You will see a channel in the sensor head, and will notice a wire running inside....you can clean this with a cotton swab with cleaner applied.....don't go to mad just apply gentle pressure.

At the side of the sensor is a metal plate within another channel...you can clean this using the cleaner and some tissue, wedge it in the grove and slide in and out....you can use a small screwdriver to exert more pressure to clean the plate and the edges.

The sensor heads..electonics is sealed so don’t worry too much...but still be careful.

When this is done....rinse the sensor head under luke warm running water from the tap and just cover the top part of the head where you have cleaned...

when done remove the MAF body that was soaking, test the mesh for cleanness with a cotton swab, if still dirty use the anti-static cleaner to clean more..and re wash in luke warm water.

Lay both the sensor and the MAF body...on a tea towel on a radiator to dry ...

Re-Fit the MAF all back together and put back on the car.


a good source of parts as follows:

http://www.shop4parts.co.uk/index.cfm/method/catalogue.list/

http://www.ebspares.co.uk/index.html

http://www.alfaworkshop.co.uk/alfa_156_parts.shtml

all the best


:)
 

·
Registered
Joined
·
14 Posts
Discussion Starter #8
:D wot a help. i will check it out this weekend. u r a top man. very helpfull. cheers again !!! :D
 
1 - 9 of 9 Posts
Top