Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi,

I have recently bought a 2001 166 that has fitted with what I presume to be a G3 ICS unit. I have the code and everything seems to work as it should on the unit apart from the sat nav.

The vehicle didn't come with an original sat nav disc when I bought it, so I bought an updated UK disc online and rather naively expected it to work when inserted into the sat nav cartridge in the boot. I am obviously missing something somewhere along the line and I would be grateful for some advice.

Here's the sequence of events that take place:

Switch on and pressing the 'nav' button on the ICS brings up this screen: Initialising navigation system


followed shortly by this screen: Please insert cd


So I insert the UK update disc that I recently bought, and I get the 'Initialising navigation system' screen again for another short while followed by this screen: Error when reading CD. Check CD!


Do you think I have bought a faulty disc or does the system need to be preloaded with something else like a sat nav operating system? I have read through loads of threads to try check and see what the software is on my ICS sat nav and I can get the following screens on my system, which are sadly, of no help to me:




I know the serial numbers of the Becker (radio?) system and the Siemans (navigation?) system, if they are of any help?

Sorry for the long winded post but everything else works on the ICS apart from the sat nav, so any assistance would be much appreciated.

Thank you.


Kevin
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Does anyone have an original navigation disc that I could borrow and try in my car please? At least through the process of elimination I will know if it's my new disc or the CD unit?

Thank you.


Kevin
 

·
Registered
Joined
·
175 Posts
Hi,
I'm no expert on ICS (or pretty much anything) but if I had to pick, I'd say take your ICS screen messages at face value, in particular the one after you insert the CD which is telling you it doesn't recognise it, strongly suggesting that it's the CD rather than the ICS unit which is the problem. I say this becos your ICS otherwise seems to be working as intended. And for what it's worth, with my 2000 rego but 99 build car, I got what appears to be the original CD (it was a one-owner car) and it works, except that it doesn't know where the car is because Bulgaria wasn't included in the Italian market sat nav cds :) But on my road-trip back in August, when I approached the German border from Poland and out of curiousity powered up the sat nav, lo, it came to life and started telling me where I had to next turn off. Only trouble was, it wouldn't let me enter the specific street in Berlin I wanted to get to - it had a bunch of preloaded streets and kept defaulting to the one nearest to the spelling I needed to put in, so I gave up on it and went back to the phone. (And then went to a street with the same name 25kms from where I needed to be, but that's another story.)

Point is, the sat nav on my 99 build still works. No bloody use, but works. I suspect it's the same on your car and it's the CD that has the problem.

Hope you get it sorted.
 
  • Like
Reactions: Grindon

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Many thanks for the advice fellas, very much appreciated.

I'll keep looking and I am sure an original disc will turn up on eBay or somewhere soon. I am not actually in urgent need of a sat nav, it's just my OCD kicking in and I need everything working!!!

Cheers,


Kevin
 
1 - 5 of 5 Posts
Top