Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
4,150 Posts
Discussion Starter #1
Mine have been doing my head in for the last while - I fold and open them every day when going in and out the garage. They were only working intermittently, sometimes I was holding the button down for ages, pushing it 10 times in a row or rocking it backwards and forwards to get them to work.

I have been meaning to check for ages - Remembered the other day on way into garage, only took a few minutes and now they work perfectly :)

I took the switch out and opened it up - The circuit board was very slightly white (I guess rain ran in or some condensation), I gave it a quick clean and put it back together - All fine!

Hope this helps somebody else.
 

·
Registered
Joined
·
19 Posts
I've been having a similar problem with my left hand mirror, won't fold in at all. Even if I flip the switch on the drivers door to control the left mirror the right one still folds in.. or out.

Is this the switch you opened up, and how?

Dougie166, help! This mirror has really bugged me for ages.
 

·
Registered
Joined
·
4,150 Posts
Discussion Starter #5
I've been having a similar problem with my left hand mirror, won't fold in at all. Even if I flip the switch on the drivers door to control the left mirror the right one still folds in.. or out.

Is this the switch you opened up, and how?

Dougie166, help! This mirror has really bugged me for ages.
Yeah, same switch. The switch to choose left or right hand side mirror is for movement of mirror only. You cannot fold one mirror at a time, both mirrors should fold in together at push of button.

Switch is simply prised up and out of door panel, then prised open, cleaned and all put back together.

Sorry but it would seem that you therefore have more of an issue - Maybe a broken or disconected wire?
 

·
Registered
Joined
·
7 Posts
Been having lots of problems with my mirrors on my 166, left one is always sticky, sometimes not extending fully until on the move. The right one has started to click and not move except for a jumpy movement. I think I'll try the switch cleaning first then go from there.
 

·
Registered
Joined
·
19 Posts
Cheers Dougie, think your right about a broken or disconected wire, only just got the car back from my local dealer, was in due to a electrical fault but looks like theres still some lingering problems. Why am I not supprised, think its time to check out local indy alfa specialist.
 

·
Registered
Joined
·
1,854 Posts
ah this thread hopefully tomorrow will make my day when i can get my drivers side mirror to fold in....

on a seperate note, when i move my passenger mirror it doesn;t move as much as it should - is it easy to taek the mirror out and check its clearence or not worth it?
 

·
Registered
Joined
·
24 Posts
You may have your problems solved but I had same problem on 166. Just check that you can hear the motor running in the troublesome mirror when you press the switch. If it is running then it is likely to just be the actual wing mirror is loose - tighten the screw / allen head underneath the mirror. It is easy to take off wing mirror - just remove the plastic cover on inside of car (one allen head screw), then there are 2 / 3 allen bolts inside frame. Once everything is put back tight, it will be fine. I think car washes knock the stuffing out of them and also if you use it regularly then it comes a bit loose.
 

·
Registered
Joined
·
36 Posts
Sorry for digging up a old thread, but I've came across two fold in mirrors and I'm thinking about buying them for my 166 -99.
Since the car's not equiped with these when it was sold, I'm missing the buttom too and was wondering if anyone could take a picture of it and where it's located?

My car didn't have this option, so I guess there are no harness in it for this?
 

·
Registered
Joined
·
254 Posts
its part of the switch panel on the drivers side door, with the windows buttons. you might have the harness there check if there is any connectors taped to the loom under the switch panel or at the mirrors . i dont think its worth it though ..i always leave them unfolded.. i d rather have someone drive too close and smash the mirror than the side of the car...
 

·
Registered
Joined
·
6,300 Posts
i didn't know that they did them with no fold....seems very mean!

By the way, i love that avatar....how mean does that 166 look coming out that corner!!
 

·
Registered
Joined
·
254 Posts
i didn't know that they did them with no fold....seems very mean!

By the way, i love that avatar....how mean does that 166 look coming out that corner!!
It also looks like it has a lot of bodyroll :lol: , but the 166 does look great when it tilts , its still so elegant
 

·
Registered
Joined
·
36 Posts
It also looks like it has a lot of bodyroll :lol: , but the 166 does look great when it tilts , its still so elegant
Thanks for the comments.
Well, it's a 3.0 V6 sportronic which I've autocrossed a couple of times. It's not the fastest car, but it's very fun! And yes, it's soft! Actually, I think it's too soft for street driving too...
Bone stock suspension, mostly because it's my daily car. As you can see at pic2, it doesn't like trail braking...

The red one is my trackdaycar. The 166 is only a stand in when the red one is broken...

Bobda; Thanks, however I'll try to buy everything from the same place since shipping otherwise probably will be more expensive than the parts (I live in Sweden...)
 

Attachments

1 - 17 of 17 Posts
Top