Alfa Romeo Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hello guys

Could anyone please advise how much a genuine Bosch MAF is for a 166 3L V6 (99 plate) and the best place to purchase one. Thanks in advance. Geoff
 

·
Registered
Joined
·
10,019 Posts
Welcome,

Let us know how you get on :thumbs:

Coming from a 155 how do you rate the 166?

155 TS Super was my first Alfa - hooked ever since :D
 

·
Registered
Joined
·
7,120 Posts
now I did read on here somewhere a Vauxhall 2.5 engine uses the same sensor only in a different diameter tube, and the cost is about £55 so the extra £120 is just to put the sensor in a different tube :mad:

I will try to track it down...
 

·
Registered
Joined
·
741 Posts
I might have the old one off my scrapped 1999 3.0 V6, so pm me of you want a cheap one ot get you going. Understand you might want a new one, so no worries.
 

·
Registered
Joined
·
7,120 Posts
I cannot seem to find it, but remove the MAF, get some of those security torx bits and remove the sensor from the tubing. On the sensor itself these is a Bosch part number and order than instead. I think the Vauxhall 2.5 V6 came out cheapest, some guy spent time cross referencing the Bosch catalogue for shared parts.

HTH
 

·
Registered
Joined
·
10,019 Posts
I cannot seem to find it, but remove the MAF, get some of those security torx bits and remove the sensor from the tubing. On the sensor itself these is a Bosch part number and order than instead. I think the Vauxhall 2.5 V6 came out cheapest, some guy spent time cross referencing the Bosch catalogue for shared parts.

HTH
Yup, I remember that thread but couldn't find it either.

Posted the links because he wanted genuine parts but was :eek: when I saw the price.

Try GTA Italian car Sales. ISTR they replaced mine before I purchased her so being a trader I doubt they pay full whack - worth a try.

Thirdly, give Jason @ Donald's Alfa try
 

·
Registered
Joined
·
12 Posts
Hi, an old post for a new problem on my 3l
I had misfire with the maf plugged and normal with maf disconnected.
i ordered a brand new maf but even with the new one plugged it misfires.
What else could it be ?
It started misfire just after i plugged my battery off and on to change my isc screen
Can i run it maf off?
Thks
 

·
Registered
Joined
·
539 Posts
Hi, an old post for a new problem on my 3l
I had misfire with the maf plugged and normal with maf disconnected.
i ordered a brand new maf but even with the new one plugged it misfires.
What else could it be ?
It started misfire just after i plugged my battery off and on to change my isc screen
Can i run it maf off?
Thks
Get the car plugged into a code reader like multiecuscan to see what the engine says is wrong before you start spending money.
 

·
Registered
Joined
·
6,032 Posts
Just to say you can't read the fault codes using the free version - you have to pay €50 for multiECUscan
Worth it IMO.
Do you have a cable?
 

·
Registered
Joined
·
12 Posts
Hi, I removed the maf, cleaned it with break cleaner, i put few in the tb also while my girlfriend pressed the pedal, let it dry one hour and it worked. My old 166 runs as new. Happy it was the maf and not a timing belt trouble
Thanks
 

·
Registered
Joined
·
501 Posts
Keep in mind all TS and 2.5/3.0 use the same maf.
Ends with ...030 for a Cf2 maf and from late 1999 enda with ...044 for a cf3 maf.
 

·
Registered
Joined
·
6,032 Posts
Keep in mind all TS and 2.5/3.0 use the same maf.
Ends with ...030 for a Cf2 maf and from late 1999 enda with ...044 for a cf3 maf.
Thanks for confirming - that's what I thought
 

·
Registered
Joined
·
501 Posts
Thanks for confirming - that's what I thought
Yeah and if I recall correctly the right CF2 maf was actually used as early as in 1.6TS 146 or something.
A CF2 v6 will work very well with a CF3 maf but it will be a slight bit down on power and not be as edgy and fun. Runs nice though.
 
1 - 19 of 19 Posts
Top