Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
267 Posts
Discussion Starter #1
Since I got my 164 back in action I've noticed that the light on the dash indicating the bonnet is open (??) is constantly flashing. I think I might have disturbed the wiring to the bonnet switch when I was clearing dead leaves out from around the bulkhead, not sure. I've got the alarm siren switched to off in the boot.

I'm not sure why this light keeps flashing (it does it ignition on or off and when I'm driving) and I'm a bit worried about battery drain.

Does anyone have any info on its behaviour?
 
G

·
Guest
Joined
·
0 Posts
Hi Tom had a problem like this it's the alarm active light that normally comes on when the car is locked I think ? Mine was working back to front ie:- it went off when you locked it and on when you unlocked it I think it got confused when the car was unlocked with the key with the battery off and then reconnected if that's any help but had to disconnect battery and lock unlock with the key then then reconnect and use the remote . Had to go through this a couple of times till it worked .
The bonnet has a separate alarm push switch on mine there is no lock/catch switch on my car it's the one up on the bulkhead
 

·
Registered
Joined
·
267 Posts
Discussion Starter #3
I think what is happening is that my car possibly thinks the alarm is going off. With the car locked and the boot open I turned the key in the boot to turn the alarm tone on and it started sounding so I turned the key back again to turn the siren off. My understanding of the keyswitch in the boot is that it only deactivates the siren, not the alarm system as a whole?

The plunger switch on the front left bulkhead is for the alarm to detect that someone's opened the bonnet I'm guessing?

It's not the end of the world, I think car alarms are useless so I have the siren off anyway, and so far the red light hasn't been causing a battery drain issue, but I would like things to work as they should!
 
G

·
Guest
Joined
·
0 Posts
yes the plunger is the bonnet alarm switch.
did you check the wiring on it could be a dry connection in the switch or the wiring?
if you've had a lot of leaves in there it may have got damp and a bit corroded.
I don't think the flshing light is a bonnet open I'm pretty sure its just the alarm active light I didn't know that it was even there until it started playing up!
 

·
Registered
Joined
·
267 Posts
Discussion Starter #5
Using a highly technical method I've stopped the dashboard light from flashing by removal
of the 3A and 10A fuses in the boot. Owners manual says these are alarm siren and alarm respectively. I've got a 15A fuse in the boot too, no idea what it's for?

Not a big fan of car alarms, everyone just ignores them so what's the point? If any potential thief can bypass the Code system then good luck to them! Sometimes it's hard work even with the key!
 

·
Registered
Joined
·
2,518 Posts
I've tinkered with my alarm on and off quite a bit. I seem to remember that when I bought it the light you mention always flashed. You can disable the siren directly with the ignition key. Small flap on the right side of the boot gives you access. The siren has its own power source (I think through capacitors) so removing fuses can actually set it off.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #7
Siren already disabled with the key. Removing the fuses has stopped the light from flashing. It was flashing all the time, even while driving, which I found distracting. I'm sure it should only flash when you lock car and arm the alarm with the remote??
 

·
Registered
Joined
·
2,518 Posts
After activation, if it detects a fault (door open, low voltage) the light will give repeated fast flashes for about 5 seconds. If everything is ok, it should flash once per second once activated.

If it memorises a fault/intrusion, it will give you 5 seconds of fast flashes when you start up.

That's it as far as the manual is concerned but I had this issue when I bought mine which came with no remote. Basically, if you open with the key, the light will give a flash per second when running. I found a receptor and remote on fleabay (first and last I have ever seen) and started using the remote. End of the annoying flashing when driving even with the siren turned off.
 

·
Registered
Joined
·
267 Posts
Discussion Starter #9 (Edited)
Ah! I do have the original remote and two aftermarket ones that are programmed to the car. The original is temperamental and I think I may have unlocked with it but then it wouldn't lock or maybe the other way around. Something along those lines. This may explain it, thanks.

Edit: just been out and replaced the fuses and unlocked with the original remote and it's sorted. Thanks :)
 

·
Registered
Joined
·
2,518 Posts
Result! Glad to help.
 
1 - 10 of 10 Posts
Top