Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,

Bit of a newbie here, been running a 164 3.0 auto on a K plate for the last 6 months or so.... it managed to pack up on Xmas day on the way to Weston super Mud with a shredded fanbelt. Anyway, £ 300 worth of tow later in Weston, the next day I bought a new fanbelt and discovered that the reason it went was the A/C pump pulley had seized. Does anyone know whether the A/C pumps in the 3.0 were the same in all model years? I've found a second hand one off a G plate, but I dont know if there were any changes and no-one seems able to tell me..... If anyone knows, can you let me know? I've been reduced to driving the Skoda Favorit I bought to get me home to Dartford ever since, while the Alfa languishes at the side of the road with the alternator and radiator hoses removed. Go on, spare me the indignity, and help me get the Alfa going again! :)

Many thanks,

Mark
 

·
Registered
Joined
·
518 Posts
the pumps from a 12v are different to the 24v models, not sure what yours is. If it has the same type of pulley (grooved belt type) then it will be ok. Pulley seizing is not uncommon. If yours is a V type pulley then you will need the same type. They are available new at about £350 or there is a brand new one on Ebay which I think is the same for £99!! or get a used one and get the bearing replaced.
 

·
Registered
Joined
·
2,060 Posts
The earliest 164s (F, G, H and maybe J?) had a big "V" belt but later ones (even 12 valves had a ribbed "poly v" belt. Obviously the pulleys will be completely different.

At some point (might have been after "K") they would have changed over to the modern "R134a" refrigerant because the older "R12" refrigerant was banned. The two are completely incompatible and the seals in one compressor won't be suitable for the fluid in the other system. There should be a plate or sticker under the bonnet that says what refrigerant your car uses.

Finally, what seized? Normally, if the aircon isn't actually switched on, the pulley just "free-wheels". There's an electromagnetic clutch inside it (that's the "tick" you hear when the aircon is first switched on). It might just be the clutch that has failed in some way - in which case, depending on whether or not you actually want your aircon back, the simplest solution might be just to change the pulley (thus avoiding discharging the system) and leave the compressor siezed forever. Just make sure you don't connect up the wire for the electromagnetic clutch and it will never try to cut in.
 

·
Registered
Joined
·
518 Posts
The pulley has no bearing, the bearing is in the pump itself (I am pretty sure anyway) with the pulley simply pushing onto the shaft. If that bearing seizes you are stuffed, usually takes the pump out as well. Might be possible to replace the bearing in the pump but it still means taking it off, might as well get a new one.

Mike
 

·
Registered
Joined
·
2,060 Posts
I disagree - the pulley must have its own bearing because it needs to be able to turn when the pump is stationary (i.e. aircon switched off).
 

·
Registered
Joined
·
518 Posts
You are of course absolutely right, must have been thinking of something else.

The easiest way to tell if clutch seized is to see if centre turning instead of just outer part of pulley when aircon switched off, if pulley turns but pump shaft does not then its probably the pump. I suspect the pump has seized because even with a seized pulley/clutch the pump would still turn...?

Mike
 
1 - 6 of 6 Posts
Top