Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
107 Posts
Discussion Starter #1
Drove 170 miles today at around 75-85 on cruise, then got stuck behind a 40mph hgv for a minute - put my foot down to pass him and nothing happened! basic speed was 40 mph, accelerated but Turbo guage was on 0 stuck on bottom of guage. . . Limped passed, built up to 60, then started working again!

All very worrying, EGR valve replaced 2 days ago. Have i bought a lemon ?
 

·
Registered
Joined
·
700 Posts
Bit hard to diagnose,

No power from 40mph sounds very much like limp mode.

That can be caused by any number of things, If the EGR was replaced 2 days ago you might find that the ECU is still re-learning its settings (if the battery wasn't disconnected during EGR replacement)

It might have gone into limp mode whilst at the lower speed then cleared after a minute or so whilst building up to 60.

Just drive it and don't worry about it for now, If something is wrong the symptoms will reappear and you can post more info which might shed more light on it.

Merry Christmas,

Axe.
 

·
Registered
Joined
·
8,786 Posts
Limp mode always makes the engine malfunction light come on... and you'll definitely will be able to go faster than 40 Mph...

It reeks as an egr issue, but that valve was changed you say...
 

·
Registered
Joined
·
107 Posts
Discussion Starter #6
Well drove 400 mile round trip today, sweet as a nut and absolutely flew back! . . . Can't work out for the life of me what happened the other day but don't want to experience that again, putting foot to floor and nothing happening, quite scary in outside lane.

Think I'm going to get dpf and egr deleted. . . Other than that, I absolutely love driving this car.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #8
Do it... Let this childish 19JTDm to be a real man enough...
:biglaugh:
I can easily replace the dpf and blank the egr valve myself - However am i right in thinking someone is needed to change the setting in ECU ?

Also, i like very much the idea of clearing out my own dpf making it a straight through rather than a replacement pipe . . . Ill get on this in the new year.
 

·
Banned
Joined
·
3,110 Posts
I like this idea since strip of DPF, EGR, HeatEXch. and different support brackets thereof saves about 15 kilos.
To modify ECU you should go to remap- company.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #10
Problem occured again today...after getting on M5 getting up to 75 on cruise, after 15mins got no power! Dropped into 5th, then 4th, no throttle response but maintained 80mph no problem.
Boost guage in car sat on 0.2 and no more Tha that.... After bout 10miles started working again , full power for next 150 miles!....
 

·
Registered
Joined
·
701 Posts
So it happends when it regenrates the DPF...Strange cos mine is doing exactly same way after my cambelt snapped (all good & 100% cam is correct aligned again by marks on belt)..& seems to lack a bit of power at low revs (EGR blinded). Do you have power/turbo-surges sometimes in 5. & 6. Gear at medium-high loads? (Like when going uphil at 60 with speedpilot on? )
 

·
Registered
Joined
·
107 Posts
Discussion Starter #12
So it happends when it regenrates the DPF...Strange cos mine is doing exactly same way after my cambelt snapped (all good & 100% cam is correct aligned again by marks on belt)..& seems to lack a bit of power at low revs (EGR blinded). Do you have power/turbo-surges sometimes in 5. & 6. Gear at medium-high loads? (Like when going uphil at 60 with speedpilot on? )
90% of my driving is on motorway at speed, then ten- 15 mins of normal 30-40mphs.

When the car " fails" it's as if the throttle does nowt, non responsive. Will creep up to 80 but there's no real power, and the gauge on dashboard hardly moves ( turbo gauge)

This has happened twice now in two weeks of owning this car. The EGR valve was swapped for a brand new one. I'm hoping this is an easy fix as money is a bit tight having just bought the car, and post Christmas.

As soon as I get some dough I'll look up the lad in St Helens and get the egr blanked, straight pipe, and a mild remap.

If that cures it I'll be happiest chappy on the planet, if there's an underlying problem I ain't gonna be best pleased.

Love the car, much heavier on fuel than I thought it would be ( it's no better than my merc c320cdi ) and that was 3.0v6 !

Let you know how it all goes...

Thanks
 

·
Registered
Joined
·
222 Posts
Mine did something similar ages ago and the end result was the outlet from the turbo had come off which resulted in zero manifold pressure and an car barely able to accelerate(but not showing any engine light on), so the compressor was spinning, but just venting all the boost pressure to atmosphere!!!
 

·
Registered
Joined
·
8,786 Posts
had a car in today with similar symptoms.

fuel filter clogged. couldn't deliver enough fuel when demand was high.

worth a punt, demand is definitely high during regens and turbo boost is also kept lower
 

·
Registered
Joined
·
974 Posts
Did you check for any fault codes via OBD? Having three iterations of the 2.4JTDM £25.00 for a decent OBD was a no brainer..

I had this problem a long time ago on a 159, well it had a variety of other issues I fixed. But still, the inlet manifold was junked. Started by an odd loss of power (turbo), then fault codes showing up saying injector issues, then came EGR issues, then rough idle in cold etc. etc.

I thought originally it was the Turbo, I was very much mistaken.
 

·
Registered
Joined
·
107 Posts
Discussion Starter #16
Did you check for any fault codes via OBD? Having three iterations of the 2.4JTDM £25.00 for a decent OBD was a no brainer..

I had this problem a long time ago on a 159, well it had a variety of other issues I fixed. But still, the inlet manifold was junked. Started by an odd loss of power (turbo), then fault codes showing up saying injector issues, then came EGR issues, then rough idle in cold etc. etc.

I thought originally it was the Turbo, I was very much mistaken.
No I don't have that tool if I'm honest..... I did have rough idle when cold, but that's now fine since new egr fitted. .

I'm going to speak with alfatune, remove dpf and blank egr, get a remap and possibly a new exhaust system. See How she fairs from there.... I'm confident alfatune will be able to set my mind at rest.

Need to get a quote off them for he work then get some funds together after this Christmas milaky.

Thanks.
 
1 - 17 of 17 Posts
Top