Alfa Romeo Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
30,126 Posts
Discussion Starter #1
Hi.

Some of you may recall that I recently had the drivers side wiper arm changed as it was hitting the bonnet, cutting a groove in the arm & damaging the paint (underside so not visible).

I immediately noticed that at the top of the up-sweep, a 2 inch bit was getting missed. I reported this to Variava's.

It's now getting worse and the un-swept bit is getting bigger.

I turned the car off when the wipers were at the top of their sweep & I had a look.

That 2 inch bit is getting missed because the blade is not in contact with the screen:eek: To top it off, I've also noticed that the arm is starting to wear on the bonnet again:(

I've been in contact with Darren at Variava's via email and I'm awaiting a reply. The round trip to the dealers is c140 miles so I might have to look at using Guests again.

Any ideas for a quick DIY fix as with all this rain, it's a nightmare:mad:
 

·
Registered
Joined
·
47 Posts
Hi SR

The problem is the the wiper rack is not aligned properly under the plastic. It can be reset so the wipers push harder against the screen and clear the bonnet. Had this on mine a while back, worked it out and got the dealer to adjust it as it was really a pain not to be able to see out of a large portion of screen.

Really should post here more instead of Lurking....
 

·
Registered
Joined
·
307 Posts
Try guests mate. They had my car last week for some warranty work and were top notch once agsin. They'll even wash it for you... you can have a week off!
 

·
Registered
Joined
·
123 Posts
What PJames said - Quite a well known problem. I've heard of some simply bending the wiper arm. I had the dealer fix it for me. Possibly just bent the arm :)
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #5
My dealer didn't seem to know about the rack problem but the chap (DET) I spoke to at Platt's did. I'll try Guest's. Chris. Please PM me you surname;)
 

·
Registered
Joined
·
433 Posts
SR,

A disgrace. Variava should be giving you a tank of fuel plus some service vouchers to compensate you for their inability to resolve this.

A friends wife has a Audi Q7 and complained about tyre wear with back-up from an Audi Forum (GY Eagle F1 GSD3s) and she got 4 x new tyres and a full tank of fuel for the hassle......
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #7
The car is booked into Guest's for next Wednesday. variava's are aware.

I must say that I was impressed with Guest's service reception & Parts:thumbs:

The parking situation is still dire there though and I always fear for my car when it's left (door dings, parking scrapes etc.).
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #8
Took car in this morning. Very well treated and Chauffeured to work by their service manager. Got to speak to the DET and showed him exactly what the problem was with the wiper and also the paint protection film on the rear of the side skirt (been on back order for over 6 months:mad:). Will keep you posted:)
 

·
Registered
Joined
·
59 Posts
As posts below, the wiper arm seems to be a known problem. Donalds couldn't deal with it initially (no Alfa mechanic), but fixed it two weeks ago. Apparently caused by incorrect attachment, and requires wiper arm to be removed and refitted.

Seems to be a common problem.

Hope it gets sorted.:thumbs:
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #11
Didn't you have this problem on the other car too Simon?
:confused:
I did Nev; on the GT. Weird but I'm not alone (pal with Brera (not GTleigh) has the same issue.

Deler has called. Wiper rack realinged and wipers now working properly and replacement arm (current one is slightly marked from contact with the bonnet) is on order:)
 
F

·
Guest
Joined
·
0 Posts
Thank goodness I've found this forum. My 159 suffers with the same problem, not wiping in the centre of the drivers side, think dealer thinks I'm making it up!!!
Now I can inform them that it's a known problem.
Thanks guys.
 

·
Registered
Joined
·
69 Posts
I'm interested about the repositioning of the rack as I instigated the bending the wiping arm improvement and although the blade now sweeps all of the windscreen the amount of pressure put on the blade is minimal. Insects' remains on the windscreen just smear across the whole screen and I did almost 700 miles on Thursday, mostly with the wipers on, due to our wonderful weather, and the smears remained the whole day.:(
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #14
Mine is great since Guests:cool:
 

·
Registered
Joined
·
325 Posts
Mine was wiping OK but when I had the cracked screen replaced by Autoglass they noticed a mark on the arm as it was slightly rubbing the edge of the bonnet. Reseated and aligned for me during the replacement OK..........Only issue now is that the rubber at the drivers lower edge now needs re-glueing as its lifting :(
 
F

·
Guest
Joined
·
0 Posts
Had my car serviced and mentioned the wiper problem, told them about this forum and how it seems to be a common problem. To be fair they seem to have solved it, car runs really well after the service too. ....................Perry's of Amersham if anybody's interested.
 

·
Registered
Joined
·
154 Posts
I have read these posts with interest and had thought my April 2008 build car wouldn't suffer from these troubles, because of course they would have sorted it at the factory by now wouldn't they?:cheese:

No!:rant:

600 miles and it started missing a bit at the edge of the drivers side. I had a look with the wipers at 'full wipe' and the base is very close to the edge of the bonnet, so, that will be my first trip back to the dealer then.:(
 
F

·
Guest
Joined
·
0 Posts
My wiper on the drivers side was not wiping an area in the middle of the blade, not easy when driving at speed during heavy rain as the water just pools. The blade had no pressure at that point, I considered bending the arm to increase the pressure but decided to leave it to the dealer.
 

·
Registered
Joined
·
28 Posts
I have just noticed that mine 159 is doing this as well its an April 08 version. The wiper is clearing the screen fine, but I noticed what looked like a strange dirty patch on the bonnet. Its the paint that has been rubbed off by the arm! I've only had the car a few weeks, and have been very happy so far.
The car's not due for a servcie until April and the nearest dealer in 80 miles away - don't know how bad it will be by then though.
 

·
Registered
Joined
·
30,126 Posts
Discussion Starter #20
The arm material will be softer than the bonnet but it's still not something I'd leave TBH:eek:
 
1 - 20 of 24 Posts
Top