Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
This is my 159 2011 TBi, sold here as the 'Elegante' trim level, including most of the comfort accessories (electric leather seats, sunroof, etc.) and, surprisingly, factory installed lower suspension, larger disk brakes and 18 inch wheels - making it similar to the TI.

I've had it for a few months and recently have a strange problem - when turning right with relatively high g force, when the body is rolling significantly to the left, I feel strong vibrations coming out from the front left side.

This is not dependent on speed (can happen on low and high speeds) and on steering angle, but mostly dependent on body roll. May also happen when front left wheel drops into a pot hole and goes back up quickly.
the vibrations has constant frequency (not 'rubbing' but rather 'knocking' in constant pace) and shakes the car quite a lot.

The car was examined by several alfa experts who didn't find anything. Both front driveshafts were replaced (you can imagine the cost...), steering angles were checked and aligned, tires swapped front and rear, and...nothing! nobody has a clue. :thinking:

Did any of you hear or encounter such a problem?
 

Attachments

·
Premium Member
Joined
·
1,161 Posts
What about the shock absorbers?
If they are turning bad it could also result in a vibration as the suspension may start to oscillate
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
What about the shock absorbers?
If they are turning bad it could also result in a vibration as the suspension may start to oscillate
I have adjustable yellow Koni shocks that were replaced about a year ago. Tried to adjust them to different settings, but this doesn't help.

It may be a good idea to put stock shocks and see if it helps. Thanks!

BTW, this is the only modification I have, the rest is 100% stock.

Did anyone encounter problems with these yellow Koni shock absorbers?
 
1 - 3 of 3 Posts
Top