Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello everyone, please help?:)

i have bought a 159 tbi 1750 sw 2011, and everything seemed to be in good shape, but then in a very short while i started noticing a viration in the front of the car. I probably didn't notice it at once because i didn't know the car yet.

The vibration is sometimes on the right side and then sometimes on the left side. Never on the same side at once. Sometimes it feels like the vibration is close to the middle of the car around the gearbox/clutch area.

The car has followed all the services and seem to be in very nice shape,except for this problem. I talked to an Alfa mechanic and he suggested that i should change the drive shafts, i did on both sides, but that didn't help......

The vibration is only there when i let go of the gass pedal... When i push the gass pedal again it is gone. Very strange.

So in short, the vibrations start when i let go of the gass pedal, when decelarating, usually between 2800-2000rpm

Please help me if you have some ideas on how to solve this problem:)
 

·
Registered
Joined
·
127 Posts
I have had this as well on my 1750 TBI Spider since it was new.
It seems it's a feature.
Mine does it not always but over 2500 rpm....let's say I release the pedal at 3000 rpm, I can feel the vibrations until 2500, then they dissapear.
What I've noticed is that it only does it when I've been giving a lot of throttle and release after a heavy acceleration...
 

·
Registered
Joined
·
61 Posts
Yes, I have the same "character" feature as described above. Maybe the variable cam shafts can't adjust good enough when you drop the throttle all of a sudden (?).
 
1 - 3 of 3 Posts
Top