Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter #1
Bugger! :cry: , had my 06 159 for just over 3 months and its all gone a bit pear shaped, firstly, still waiting to have my EGR valve replaced (under warranty, but been waiting over 6 weeks for the part!) recently heard a bit of a squeek similar to a sticking brake pad when turning the wheel but over the last few days at low speed the steering is making a right racket which can also be felt through the steering wheel and I'm loosing fluid through the filler reservoir so it's sat on the drive at the moment as I don't think it's safe to drive, whats also concerning is an occasional smell similar to burnt electrics like when a motor fails (i noticed this about a week ago but at that point the steering was quiet) so I suspect the ps tensioner has failed and the smell?, could that be a pressure switch thats gone?, as i said it's just out of warranty so I'm on to mangoletsi on monday as it appears to be a common failure.

Ian
 

·
Registered
Joined
·
529 Posts
I had the power steering issue you mention just before Easter. I was reversing into my garage when I noticed the steering felt heavy and that there was a vibration through the wheel and a droning noise coming from the engine bay when the wheel was moved. Popped the bonnet up to find the power steering fluid was leaking out the reservoir cap. I left the car overnight after cleaning up the fluid and it seemed fine the next morning for all of 20 miles or so before getting noisy and heavy steering again.

I took it to the dealer who confirmed the power steering pump had packed in. They didn't have one in stock so would order it and put me in a courtesy car in the meantime. The pump arrived and was replaced, however, the new pump started to make a similar noise when road tested. The car was further inspected to discover the power steering hoses had 'collapsed' and were preventing power steering fluid from circulating which in turn caused the pump to run dry and fail. In addition to this, the hoses were not in stock and as it was the week leading up to Easter, I had to wait until the Tuesday/Wednesday of the following week to get my car back. I would therefore suggest you point this out to Mango's, although they may already know, as this is a common failure apparently and Alfa Romeo UK have issued a 'tech note' which is available to all dealers, to highlight this issue. Unfortunately, my dealer didn't check this until the new pump started to make noise. If you search for '159 power steering', you will find quite a lot of info on the topic including a known issue of the incorrect steering fluid being added at build.

With regard to the burning smell, could this be a result of a DPF regen? Just a thought.

Hope this helps.
 

·
Registered
Joined
·
64 Posts
Discussion Starter #3
Thanks for that, I'll update on monday after I've spoken to Mango's.
Wallet at the ready!
 

·
Registered
Joined
·
64 Posts
Discussion Starter #4
Cars fixed :) excellent service from the guys at Mangoletsi :thumbs: was expecting to have to pay for a new steering pump (but Ken the service manager was in touch with ARUK as my car was only 5 weeks out of warranty) all it needed was a new power steering fluid reservoir and new fluid (the green stuff not the reddish brown wrong stuff that was in) job done! all for £91:D.
 
1 - 4 of 4 Posts
Top