Alfa Romeo Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
5,064 Posts
Discussion Starter #1
Had my 159 serviced by SimplyAlfa yesterday.
The 72K service including cam belt. All fluids and filters, water pump as the belt was off and a thorough going over.
I was a little paranoid of suspension issues having read about some of the problems on the forum, so asked for this to be checked.
And nothing needed doing!
Really enjoyed the 25 mile drive back home, felt really taught and great to drive.

In comparison, the last car I had, 2003 Saab 9-3SS 2.0t, was a dog. I had it at 50K and sold it at 65K. Had nothing but problems with suspension, steering, aux belt, etc.. Cost me a fortune.

Have both fingers crossed as I write this, but, the previous idea that Alfas were destined for the breakdown truck, seem totally unfounded to me! Touch wood, turn round 3 times...

Great car, love the ownership experience so far. Have done 12K miles in 6 months, looking forward to the next 12K and beyond.

Cheers
:)
 

·
Registered
Joined
·
15,180 Posts
:thumbs: Good news
 
U

·
Guest
Joined
·
0 Posts
I'm only 30,000 miles behind you!

Still got all the bits attached to mine I think - windscreen wiper mechanism being replaced under warranty on Monday
 

·
Registered
Joined
·
919 Posts
My 159 at 50k was still solid.

We have a 56 plate 159 at work with 92k on it and although I haven't seen it for a while as it's not based near me I'm told it's still all good. When it comes back it'll have 100k and I'll have a good look at it to remind me why I should trade my Mondeo for another 159 (2.4 JTDm)
 

·
Registered
Joined
·
1,764 Posts
Great to hear fella! :thumbs:

Look forward to hearing your 90k report :D
 

·
Registered
Joined
·
318 Posts
I'm 30k miles behind you and I need to get new steering rack, and because my warranty is run out i gonna have to pay for it :cry:, loads of money (700-900 pounds I've been told ). Well done I love my bella so I;ll forgive her :p
 

·
Registered
Joined
·
7,179 Posts
I too am worried about the PAS, my first 159 blew all ts fluid out, the second is on its second pump and its noisy.

Would put me off owning one beyond the warranty.
 

·
Registered
Joined
·
5,064 Posts
Discussion Starter #9
Got the mechanics to check that the correct fluid was in the power steering pot. All was as should be. Phew. As it is an April 2007 car, I think it must have been changed at some point?
I was dreading the same thing after reading on here about issues with pump.

Will update as the miles clock up........
 

·
Registered
Joined
·
11,159 Posts
That's great news! we just turned 46k with only 1 minor gripe ( see "power steering broken" thread), giving me a little more faith in AR crossing fingers still just a little looser now! :lol:
 

·
Registered
Joined
·
11,159 Posts
Sorry that was meant to be "steering rack bust" thread.
 
1 - 13 of 13 Posts
Top