Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello everyone. Despite my best efforts to find a solution on this forum and the elsewhere on the internet, I've hit a brick wall with this one. My air con doesn't work and the fault has been diagnosed as my compressor needing to be replaced. So I provided my VIN number to several suppliers all of which confirmed the same part I need. I ordered it, but on arrival the new one has a different plug connector to the old one and doesn't appear to be compatible. I've triple checked and whatever source I use it says that the new part have is the new one for my car (also matched to make, model which is a 159 SW 2011 2.0 Jtdm 170 Ti). The OEM part number on the old one would suggest that the new part I have received is the correct one...but they are obviously not the same. Can anyone help me please?:banghead:
 

Attachments

·
Registered
Joined
·
563 Posts
Hello everyone. Despite my best efforts to find a solution on this forum and the elsewhere on the internet, I've hit a brick wall with this one. My air con doesn't work and the fault has been diagnosed as my compressor needing to be replaced. So I provided my VIN number to several suppliers all of which confirmed the same part I need. I ordered it, but on arrival the new one has a different plug connector to the old one and doesn't appear to be compatible. I've triple checked and whatever source I use it says that the new part have is the new one for my car (also matched to make, model which is a 159 SW 2011 2.0 Jtdm 170 Ti). The OEM part number on the old one would suggest that the new part I have received is the correct one...but they are obviously not the same. Can anyone help me please?:banghead:
If you remove the snap ring you can change the connector from the old to new unit. The rest looks the same.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
If you remove the snap ring you can change the connector from the old to new unit. The rest looks the same.
Is it really that simple and obvious!!? Most stuff on the car I've done myself, but because this is a/c I've sent to my local alfa specialist to do and supplied the part myself. They're saying it's not the right part?? You'd have thought they'd have done this before!? They're going to feel just a little bit silly (as I do right now) if all they had to do was swap the connector. Like you say...looks exactly the same apart from that!
 

·
Registered
Joined
·
321 Posts
I guess you've got the answer by now. That part is the control valve, it doesn't connect to anything. Leave it be!
 
1 - 5 of 5 Posts
Top