Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
27 Posts
Discussion Starter #1
Hi, i have alfa 159 2.0 jtdm 2010, since i have it when i turn or aircon i hear weird sound from compressor, when i press button to turn off compressor sound is gone...
Few days ago i went to dealership, to fill up aircon gas, and after i left i turned aircon on, and it was nice and quiet only noise was comming from engine and air inside cabin, also am not satisfied with cold air, its barely blowing cold, its like few degrees lower than outside, not anywhere near 16 degrees which i set. Few kilometers later it started with its regular bad sound comming from compressor...

I wanted to ask, what can cause not so cold air, they filled it up and told me to get back in 10 days, so they can check if there are some leaks, so did they filled it with some type of gas which is cause of bad cooling?

And how can i fix noise comming from compressor?
 

·
Registered
Joined
·
8,786 Posts
the gas is leaking out, they put a UV dye in to find where the leak is.

If you hearthe noise inside the carn and it was quiet right after the recharge, you're likely hearing the prematurely re-evaporated refrigerant going through the evaporator. clear sign you're low on refrigant.
 

·
Registered
Joined
·
27 Posts
Discussion Starter #3
Even before recharge, air con compressor was producing same noise and it was blowing barely some cold air, after recharge first few km it was without any noise, but it wasnt colder inside cabin...and then after few km it started making same noise again, and air was still barely colder than its outside....
 

·
Registered
Joined
·
27 Posts
Discussion Starter #5
Ok, will do when i go back to dealer, they told me to go after 10 days, so in few days it should be 10 and ill check with them
 
1 - 5 of 5 Posts
Top