Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hi all,
I've had my clutch/DMF/slave cylinder changed (and it needed it no question on that), however I got home after work the day after and it had real issues starting from hot. At any rate it was a week before it could go back in to the garage that did the work and over that time it got steadily worse at starting even from cold it still starts, just, a prod of the throttle got it going the last time I was in it (prior it'd start fine).

Fast forward a week and a half, it's had a new crank sensor which made a very minor impact on the starting, I'll find out tomorrow if new earth leads has had any impact (the battery is a couple of years old so I've had them test it while it's in). If this still hasn't made a blind bit of difference what else could it be? (hoping it's not a new starter to be honest as it still needs the gearbox sorting as well). I've searched these forums (hence the above) but so far nada on the results side.

All help is very much appreciated.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3
They did and it didn't show up anything, the mechanic was puzzled by that one, turned out to be the starter in the end. It must've been on the cusp of going belly up before the work but the new bits put the final nail in its coffin, the reason for the length of time it took to diagnose was his attempt to avoid any more big bills so was trying out all the, cheaper, alternatives. This aside I love the car (would have preferred it being a petrol engine but you can't have everything :D ).

...now I've got the drivers side window to sort (hard frost/ice and 'leccy windows don't mix well).
 
1 - 3 of 3 Posts
Top