Alfa Romeo Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
1,549 Posts
Discussion Starter #1
Car has problem no power doesn't want to go higher than 20km/h intermittently. Running fine now after stopping 3 times. They are going to mossel bay and are in beufort west right now.
It's NOT the MAF. No engine lights comes on. Uncle says it feels like the car isn't getting any juice. Is it water in fuel or fuel pump. Ideas?
 

·
Registered
Joined
·
7,047 Posts
Difficult to say unfortunately I haven’t got enough experience with them.
Maybe Walter (Wildcard) will be kind enough to check with FIAT ecu Scan if you ask him nicely.
 

·
Registered
Joined
·
861 Posts
I am currently at work on duty and will be at home in Oudtshoorn at about 17:00. I am on duty in the knysna area today. If they will be in the Oudtshoorn area at 17:00 they are more than willing to phone me on 082 929 1171 and I will help them with fiat ecu scan to do a diagnostics. It will be the greatest pleasure!
 

·
Registered
Joined
·
1,549 Posts
Discussion Starter #5 (Edited)
Thank you wildcard will let him know:thumbs:
They made it without any further interruptions from Beuford-wes to M-bay he filled it up from 1/3 to full. how high does picup sit in tank might be water in tank?
 

·
Registered
Joined
·
10 Posts
I had almost the same problem a few months ago. After the refueling I had my car sitting and when I started it again it didn't run smooth had the check engine light on and didn't want to run fast. Computer check showed 2 cylinders had no power due to bad fuel . Having the full tank empty seemed to have solved the problem
 

·
Registered
Joined
·
1,549 Posts
Discussion Starter #9
Well the car ran from Kroonstad shell till in beufort so dont suspect its diesel. It has to be water in the fuel.
Sounds like you might be right betakombra.
 

·
Registered
Joined
·
7,047 Posts
Water would be at the bottom of the tank petrol floats on it so i doubt it but i suppose nothings impossible.
 

·
Registered
Joined
·
1,549 Posts
Discussion Starter #13
Ok they got pulled over by the Police whilst going through oudshoorn and guess who makes small talk Walter. My uncle was dumbstruck how Walter knew. Small world.
 

·
Registered
Joined
·
861 Posts
LOL small world indeed!!! When i saw the car I just took a chance to ask as I seldom see a 159 in the area.
I must add when he revs the motor it takes like ages to rev. it revs very slowly.
 

·
Registered
Joined
·
1,549 Posts
Discussion Starter #17
I suspect It must be the cars fuel pump. Since he bought the car he said it over or under-fuels the car when he starts the car. Can it be fuel pump relay getting stuck.
 

·
Registered
Joined
·
7,047 Posts
With the direct injection they use a mechanical high pressure fuel pump. The pressure sensor or regulator could be faulty.
 

·
Registered
Joined
·
7,047 Posts
It is on the fuel rail and the pump is on the back of the motor if I remember correctly.
 
1 - 20 of 21 Posts
Top