Alfa Romeo Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Driving my 156 sport wagon 1.6 petrol home last night and the engine just died. Engine will turn over but won't fire. Any ideas anybody? Please :)
 

·
Registered
Joined
·
9,912 Posts
if that doesnt do the trick...assuming you do have fuel in tank ..take filler cap off engine and get someone to turn engine over on key and have a look to see if camshafts are moving
 

·
Registered
Joined
·
1,271 Posts
Dont fall for the trap of being told they will fit a new belt and see what happens.One can remove the top section to expose the cams and see how many lifters are not touching the cams.The 1.6 has better piston to valve clearance than the 2.0 litre but odds are valves are bent. So a secondhand engine at £250 could be cheaper than a repair.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #15
Ok thx my own fault then but should of been done before I bought it only put 4k on it lesson learnt :cry:
 

·
Registered
Joined
·
5,225 Posts
This is exactly the reason whyt when you buy a car its good to get the Belts and service done first off.
Regardless of what a book says.

That way you can safely know when the belts have been done.


Sorry to hear about the above. You cay get away with a couple new valves, head gasket and skim plus all the belts.

But depending on how dented the pistons are it will always runh poor due to the loss of compression.
Best bet is to find a new engine (£300) find someone to fit the complete unit.

Remembing to do the belts and may even be worth getting a new clutch thrown in while the engines out.
 
1 - 17 of 17 Posts
Top