Alfa Romeo Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Hi everyone!I bought an Alfa 156 2.0 ts (1999) 2 months ago.The airbag light is on since the first day.1 week ago,i found that the under seat and side seat airbag wire were cut at the bottom of the yellow connector.And same coloured wires were kept together with a resistor.could anybody help me for doing the correct connection?my photos are below.
 

Attachments

D

·
Guest
Joined
·
0 Posts
Is it possible that a previous owner changed the seats over??? Have your current seats definitely got airbags in them???
 

·
Registered
Joined
·
5,266 Posts
Someone has changed the seats. The originals would have had side airbags, the new ones don't most likey so they added the resistor to make the airbag ECU think the seat airbags are still there. Of possibly there is a fault in the seat airbags or the airbag ECU and they have unplugged the connectors.
 
D

·
Guest
Joined
·
0 Posts
That's what I thought. BUT, if the seats DO have airbags in (Which you can tell because it will say on the side of the seat and be VERY obvious) then I'm stumped, :lol:

I added leather seats WITH airbags to my 156 I had a while back, but as you say if you are installing NON air bagged leather seats or different seats then you need to hook up the resistor.
 

·
Registered
Joined
·
989 Posts
bodge-tastic! You've had a plank arseing around with the most tempremental system on the car :(

I'd be inclined to try and forget about it all and stick tape over the dash light!
 
D

·
Guest
Joined
·
0 Posts
Do the seats have airbags or not, that's the most important question, :lol:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
ı hope that the seats are original:(...But i need a picture/photograph to see which colour wire must be connected to which colour.At the photograph dsc04509,two same coloured wires tied together to a resistor unconsciously.Is there a way to fix these problems?Thank you...
 
D

·
Guest
Joined
·
0 Posts
Mate, on the right hand side of your drivers seat you should have a large plastic panel that says something like SRS AIRBAG on it, behind this panel will be the airbag, if you have airbags you'll have these hard plastic sections on the sides of both your driver and passenger seat, do you have them???
 

·
Registered
Joined
·
9 Posts
Discussion Starter #14
Yeah,my life not in safe:(.If i had just known the correct connection of the wires,maybe i could fix them...:((
 

·
Registered
Joined
·
4,646 Posts
the original seats of a '99 did NOT have airbags it has a weight sensor in the base.

imho, the resistor was fitted to try simulate a weight on the seat at all times.

approx 4.3k ohmns simulates that of a typical weight person
 

·
Registered
Joined
·
9 Posts
Discussion Starter #17
This switch is under the driver seat.as it seems at the photo 4510,inside of the black box.But it has no end socket...:(
 

·
Registered
Joined
·
7,032 Posts
quote
the original seats of a '99 did NOT have airbags it has a weight sensor in the base.

imho, the resistor was fitted to try simulate a weight on the seat at all times.

approx 4.3k ohmns simulates that of a typical weight person
unquote

as Sears says ! this is the only explanation ! and it happens all the time because fitting a new sensor pad
is a hell of a job !!!
 
1 - 19 of 19 Posts
Top